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1 はじめに

1.1 ハンズオンの意義

筆者が講師を務める RIETAN-FP・VENUS システムと外部プログラムによる粉末構造解析の講
習会では、講義だけでなくノート型 PCを用いるハンズオン（人に教わりながらの体験学習）も重視
している。一方通行の講義を通じて学んだ知識は速やかに忘れ去られるのが常で、なかなか血肉化し
ないからである。さらに初心者向け教材として本チュートリアルも提供することにより、実習中にメ
モを書き込めるようにするとともに、実習内容の復習や他の解析への応用にも役立ててもらい、ただ
講習会に参加しただけに終わらぬよう配慮している。

1.2 実習用コンテンツ

実習は、Microsoft Windows（以後、Windows と呼ぶ）上で多種多様なアプリケーション、すな
わち

1. 秀丸エディタ1）＋RIETAN-FP・VENUS統合支援環境2）[1–3]
2. WinPLOTR3）[4]
3. DICVOL4）[5]
4. FOX [6]
5. RIETAN-FP5）[7]
6. VESTA6）[8]
7. gnuplot7）[9]
8. ORFFE8）[10]
9. lst2cif
10. xdc
11. cif2ins
12. combins
13. sda.command
14. ALBA9）[11]
15. superflip10）[12]
16. EDMA11）[13]

1） 有限会社サイトー企画が 4,400円で販売しているテキストエディター。試用期間は 2週間で、経済的に困窮している学生
にはフリー制度がある。後述のように、本実習では 64ビット版を使用しなければならない。

2） documentsUReadme_macros.pdfを参照せよ。lst2cif, cif2ins, cif2pdf, E2Jについても、そのマニュアルに記述され
ている。

3） https://cdifx.univ-rennes1.fr/winplotr
4） WinPLOTRに内蔵されている。
5） documentsURIETAN-FP_manual.pdfを参照せよ。
6） http://jp-minerals.org/vesta/jp/
7） http://gnuplot.sourceforge.net/
8） 2016年 3月 5日のブログエントリー「ORFFE による結合角と二面角の計算」を参照せよ。
9） http://fujioizumi.verse.jp/visualization/VENUS.html#ALBA
10） http://superflip.fzu.cz/
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17. EXPO201411）[14]
18. Dysnomia12）[15]＋RIETAN-FP＋MPF_multi.command13）

19. cryscalc14）

20. TeX Live15）＋ cif2pdf＋E2J [16]
21. RIETAN-FP＋ Python16）＋PyAbstantia17）

22. Supercell18）[17]＋ cif2ins＋RIETAN-FP

を順次実行していき、手っ取り早く実戦を経験することにより粉末構造解析についての土地勘を身に
つけ、座学を補完するのを主な目的としている19）。利便性を考慮し、EXPO2014, TeX Live, Python
以外のネットで公開されているプログラムプログラムは筆者が参加者の代理としてダウンロードし、
一括インストールできるようにした。どのようにして RIETAN-FP・VENUS システムと外部プロ
グラムの連携を図れるようにするかについては、Readme_Win.pdf 中の「追加インストールの手続
き」で述べた。継続して使用する場合は、参加者が各自、配付 Web サイトで使用許諾条件を読み、
遵守して頂きたい。ファイルを介して相互に連携している上記の巨大コンテンツを Windows ユー
ザーに日々活用してもらえれば、これに優る喜びはない。
上記のソフトウェア群は

1. ピークサーチ
2. 指数づけ
3. バックグラウンドの決定
4. リートベルト解析 [18]
5. 幾何学的パラメーター（原子間距離、結合角、二面角）の計算
6. 多相リートベルト解析用入力ファイルの自動作成
7. ストリームエディターを活用した逐次リートベルト解析
8. パターン分解
9. 最大エントロピー・パターソン解析
10. 未知構造モデルの構築： 双対空間法、レプリカ交換法、直接法
11. MPF (MEM-based Pattern Fitting) 解析
12. 結晶構造と電子密度分布の三次元可視化
13. CIF (Crystallographic Information File)を出発点とする結晶学的情報の取得
14. pdflatexと platexによるリートベルト解析結果のドキュメンテーション
15. BVS・BVEL法による可動イオンの拡散経路の可視化
16. 第一原理計算用誘導構造の導出

という広大な領域をカバーしている。

11） http://www.ba.ic.cnr.it/softwareic/expo/
12） http://jp-minerals.org/dysnomia/jp/
13） documentsUMPF_multi_Win.pdf を参照せよ。
14） https://cdifx.univ-rennes1.fr/cryscalc
15） http://www.tug.org/texlive/
16） https://www.python.org/downloads/。拡張モジュール numpyも必要となる。
17） https://shinichinishimura.github.io/pyabst/。MITライセンスの下に公開されている。
18） https://orex.github.io/supercell/
19） 17, 20, 22は実演だけに留める。実習時間が不足しそうだったら、他の実習も臨機応変にスキップする。
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秀丸マクロから起動される bashスクリプト ∗.commandでは UNIX哲学のうち四つの指針

•効率よりも移植しやすさを重視せよ。
•単純なテキストファイルにデータを格納せよ。
•ソフトウェアの効率を自分の優位性として利用せよ。
•効率と移植性を高めるためにシェルスクリプトを活用せよ。

に基づき、bashはもとより grep, sed, awk, cat, head, tailなどの UNIX系コマンドによりテキスト
（ファイル）を処理している20）。4.7.3で述べるように、シェルスクリプト実行の基盤として作動する
のは組み込み UNIXプログラム BusyBoxである。本ハンズオンは BusyBoxが極小サイズ、パワー、
移植性21）、高度な安定性を兼ね備えた秀逸なユーティリティーであることを実感する最初の機会を
提供しうるだろう。
残念ながら、粉末構造解析パッケージ EXPO2014 をインストーラーに含めるのは断念せざるを得
なかった。使用希望者は登録する必要がある上、民間企業ユーザーは有償のためである。唯一の粉末
回折用直接法プログラムなので、時間さえ許せば実演したい（5.11参照）。

2 ハンズオン用ドキュメンテーション

2.1 本チュートリアルの目的と読み方

上記のように、ハンズオン用プログラムはかなり多く、しかも目まぐるしく変わる。そこで実習の
円滑な進行を図るとともに、その内容に遺漏のないように Windows 上での操作手順を以下に逐一記
述しておく。料理のレシピに相当する。随所で Evernote の公開ノートとブログエントリーへのリ
ンクを張っていることから、圧倒的な量の情報を提供できる。また一部の機能、すなわち xml2bgr,
listPPP, combins, ListReplace, sda.command, ffe2insのマニュアルも兼ねている。参加者が後日、
自分の PCに配付プログラムをインストールして復習する際の一助となれば幸甚である。
以後、本チュートリアルでは次の表記

•「 · · ·」： プルダウンメニュー（> は階層同士の区切り）
• “ · · · ”： ダイアログやメニュー中の設定・チェック項目、質問、一般の文字列
•［ · · ·］： ボタン
• ‘ · · · ’： ファイル中の文字列
•ボールド書体のアルファベット： マクロ（たとえばRIETAN）
• · · ·： キートップ

を採用するものと約束する。
ほとんどの RIETAN-FP の入出力テキストファイルは、その名前から絶対パスとピリオド＋拡張
子を除くと、同一の文字列 (たとえば Fapatite.insの場合 ‘Fapatite’）となる。以後、慣例に従い、そ
の文字列をメタ構文変数 “hoge” で代表させることにする。

20） 2017年度までは、シェルスクリプトでなくバッチファイル（Windows用UNIXコマンドを含む）を起動していた。非
力かつ時代遅れなコマンドプロンプトを追放したことの意義は計り知れない。

21） BusyBox と macOS の bash は互換性がかなり高く、既存の macOS 用シェルスクリプト ∗.command は短期間で
Windowsに移植できた。

3



2.2 併読すべき文書と解説

本文書では、1.2 で列挙した自作・外部ソフトウェアの詳細については詳述しない。必要に応じて
「粉末 X線解析の実際」 [19]と RIETAN_VENUSUdocuments フォルダー中のマニュアル、とくに
Readme_Win.pdf, Readme_macros.pdf, RIETAN-FP_manual.pdf22）を併読することを推奨する。
X線構造解析の原理や結晶構造の対称性については文献 [20]で学ぶといいだろう。
本チュートリアルと「まてりあ」掲載の入門講座 [1–3] のタイトルがいずれも「RIETAN-FP・

VENUS システムと外部プログラムによる粉末構造解析」となっているのは、互いの補完と融合を意
識しつつ両者を執筆したためである。その結果、同入門講座は単なる連載記事を超越した存在とな
り、実戦を通じて粉末回折を学ぶのに貢献しうるまでに至った。RIETAN-FP・VENUSシステムの
全体像を把握するには、同講座の併読が望ましい。

3 RIETAN-FP用入力ファイルの記述法

3.1 Tinkの文法

RIETAN-FP 用標準入力ファイル hoge.ins は配付ファイルに同梱されている各種ひな形ファイル
を元に、独自の文法に則って作成する。ひな型ファイルは RIETAN-FP のバージョンアップととも
に変更される可能性があるので、常に最新版に添付されているファイルを書き換えて使うべきで
ある。
ここで図 1にまとめた主要構文を簡単に説明しておく。

1. (1)〜(5) 注釈の書き方。注釈抜きの代入文、すなわち「変数名 = 値」だけの場合、常に変数名
と値が読み込まれ、値だけが一時テキストファイルに出力される。

2. Ifブロック。Ifあるいは ifの後ろには論理式を二つまで置ける。二つの場合は andか orでつ
なぐ。

3. Selectブロック。‘case’の後ろには、‘1, 3’（1または 3）や ‘1-3’（1から 3、すなわち 1, 2,
3）というように最大二つまでの整数を置く。‘case default’ はどの case にも該当しない場合
を意味する。

4. Go to文23）。無条件ジャンプ。
5. If・Selectブロックのネスティング（図 2）は二階層まで許される24）。
6. 回折強度を計算するためのパラメーター A(I) は先頭にラベルを置いた後、一つ以上のスペース
で区切りながら入力し、最後にそれらのパラメーターに対する精密化の指標 ID(I)（=1: 精密
化、=0: 固定、=2: 線形制約条件付き）をスペース抜きで入力する。特定ラベルに属するデー
タが二行以上にわたっても差し支えない。

7. 各結晶学的サイトについてはサイト名をラベルとし、‘/’ +純粋または仮想的な化学種の名前を
スペースをはさまずに付ける（図 3）。たとえばフッ素アパタイトの O1サイトの場合、

22） 末尾に「多目的パターンフィッティング・システム RIETAN-FP の新機能について」という和文文書を含んでいる。
RIETAN-2000を RIETAN-FPに改名した後、新機能を追加するたびに書き足していったドキュメントである。

23） ‘*Destination’はジャンプの行き先であり、実際には ‘Destination’を 任意の文字列に置き換えて使う。
24） 二階層までに留めたのは、条件分岐が理解しにくくなるためである。
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注釈

(1) # 注釈
(2) ! 注釈（しおり用）
(2) 注釈 {
(3) } 注釈
(4) NMODE = 値: 注釈 (「NMODE = 値」と同じ．変数名と値を入力)
(5) NMODE = 値! 注釈 (行全体がコメントとなる）

Ifブロック Selectブロック

If NMODE = 0 then Select case NMODE
・・・　　　　　　　　　　　　 case 0

else if NMODE = 1 then ・・・
・・・　　　　　　　　　　　　 case 1

else ・・・
・・・　　　　　　　　　　　　 case default

end if ・・・
end select

Go to文

Go to *Destination

*Destination

図 1 Tink 互換の注釈、If ブロック、Select ブロック、Go to 文。
便宜上、変数名を NMODE で代表させている。 If 構文、Select
構文、Goto 文とその行き先はエディターにおける構文カラーリ
ングの対象となる。

Nested If and Select blocks

If NMODE = 4 then

# Initial values of multiplicity X |Fc|**2 are

NSFF = 0: estimated according to the Wilson statistics.

NSFF = 1! read in from hoge.ffi.

NSFF = 2! all set at 100.0.

Select case NSFF

case 1

NCONST = 0: |Fc|s are varied during least-squares fitting.

NCONST = 1! |Fc|s remain constant during least-squares fitting.

case default

INCMULT = 0: The integrated intensity is regarded as |F|**2.

INCMULT = 1! The integrated intensity is regarded as m*|F|**2.

CHGPC = 1.0: Cut-off is at first set at CHGPC*PC.

end select

end if

図 2 If ブロックに Select ブロックが入れ子になった If・Select ブロック
の例。NMODE = 4ならば、INCMULTと CHGPCが入力される。

O1/O- 1.0 0.324174 0.485349 0.25 0.744733 01101

と記述する。この場合、サイト名/化学種名 (O1/O-)の後ろに占有率 g、分率座標 (x, y, z)、等
方性原子変位パラメーター B、ID(I) (I= 1−5)が続く25）。

25） 異方性原子変位パラメーターを精密化する場合は、B が 6つの βij に変わり、ID(I) (I = 1−10)が続く。
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図 3 Faoatite.insにおける格子・結晶構造パラメーターの入力部分。

RIETAN-FPの起動直後に hoge.insは内蔵プリプロセッサー Tink26）によって

•注釈
•空行
•If 文、else 文、else if 文、end if 文、Select case 文、case 文、case default 文、
end select文、Go to文とその行き先などの制御文

•変数名 =

•フラッグの値に応じてスキップされる行
•データ入力終了を示す ‘}’

を削除され、解析に必要なデータだけを含む一時テキストファイルに変換される。それらのデータは
80 桁以内に収まっていなければならない。RIETAN-FP は一時ファイルを再入力してから解析に移
行する。Tinkについては、マニュアル RIETAN-FP_manual.pdf中に詳述した。必要に応じて参照
されたい。

3.2 Tinkの長所と留意点

このような独特の CUI (Character User Interface)には、単一のテキストファイルさえエディター
で開いておけば、ユーザーが手入力すべき全データを見通せるという利点がある。しかも後述のアウ
トライン解析枠でしおり（ブックマーク）をクリックすれば、瞬時に目的行へジャンプできる。エ
ディターで文字列を検索するという手もある。
Tink のもう一つの利点は変数名、ラベル、注釈を含むテキストファイル中で使われるため、

UNIX系コマンドを駆使したシェルスクリプトによるテキスト処理に適していることである。正規表
現 [21]、パイプ、リダイレクトの威力も遺憾なく発揮できる。たとえば RIETAN-FP 実行用スクリ
プト RIETAN.command、MPF用 bashスクリプトMPF_multi.command、hoge.lst→ hoge.cif変
換用スクリプト lst2cif.command における反射データ出力部分27）、多相試料用入力ファイル作成用
スクリプト combins.command、逐次リートベルト解析用スクリプト sda.command に目を通せば、
そのことがよく理解できよう。
Tinkではマルチバイト文字の注釈を挿入できるが、ファイルを保存するときは EUC-JPエンコー

26） “Peter Pan and Wendy” (J. M. Barrie, 1911)に登場する妖精 Tinker Bellの愛称。妖精の寿命はごく短いことか
ら、瞬時に役割を果たす前処理ルーチンの呼称に相応しいと判断した。

27） 2016年 1月 27日のブログエントリー「反射リストからデータを抽出して CIF を作成するシェルスクリプト」参照。
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ディングで保存しなければならない。NUPDT = 1 に設定して hoge.ins 中の精密化パラメーターを更
新する際、日本語が文字化けしないようにするためである。たとえ EUC-JP エンコーディングで
hoge.ins を保存しても、日本語の注釈の一部が RIETAN-FP による hoge.ins 更新時に文字化けする
ことが稀にある。そのような場合は、文字化けする部分を試行錯誤で変えて文字化けを防ぐという対
症療法を施さねばならない。

4 インストールと初期設定

4.1 実行環境について

本実習は、64ビット版Windows28）を OSとする PCにおいて秀丸エディタが C:UProgram Files
フォルダー中にインストール済みであることを前提としている。ユーザー登録していないと、登録を
促される。32 ビット版秀丸エディタがインストールされている場合は、64 ビット版秀丸エディタの
インストールに先立ち、必ずアンインストールしておかねばならない。本実習で使う自作プログラ
ム、gnuplot、Sumatra PDF29）(portable version) は 64ビット版である。各自がインストールする
秀丸エディタも 64ビット版に統一する必要がある30）。
シェアウェアである秀丸エディタを RIETAN-FP・VENUS 統合支援環境の基盤と決めたきっか
けは、LATEXによる文書作成の支援環境、祝鳥31）（のりてふ）に関する書籍を読んだことである。祝
鳥のインストーラーまでネット公開されていることを知り、同様の環境を RIETAN や周辺プログラ
ム用に構築しようと決意した。開発を始めてしばらく経ったら、もう他のフリーソフトウェアに乗り
換えられない地点まで突き進んでいた。Windows 用に最適化されており、動作が軽快で、ボタンを
クリックするだけで主要マクロが実行でき、頻繁に改良され続けているだけでなく、正規ユーザーと
して登録すれば二度とバージョンアップ料金を徴収されないため、他のエディターに乗り換える気が
まったく起きないのである。余勢を駆って DV-Xα法計算支援環境を構築するまでに至った。
解析の対象となるファイルの名前には英数字、‘_’（アンダースコア）、‘@’、‘-’（ハイフン）だけを
使うと安全である。それらのファイルの絶対パスに含まれるフォルダー名にも同じことが言える。ま
たスペースを含むフォルダー名は避けた方がよい。
15 インチ Retina ディスプレイ（解像度: 2880×1800）を搭載した MacBook Pro で Parallels

Desktop ＋ Windows 10 を使う場合は、スクリーンを右クリックして “スクリーン設定” を選び、
“テキスト、アプリ、その他の項目のサイズを変更する” で “100%（推奨）” を選ぶ必要がある。さも
ないと、gnuplot が出力するグラフ中の文字が異常に大きくなってしまう。さらにディスプレイの解
像度を 1440×900 (0.5倍) に落とせば、プロジェクターで画面を正常に映写でき、ツールバー上のボ
タンなどが適度な大きさになる。

4.2 言語の選択とエクスプローラーの操作

1. Windowsに習熟しているかどうかを知るために、普段使っている PCについて聞く。macOSの
ユーザーがどれくらいいるかが把握できる。

28） Windows 7以降と互換性があるが、将来性があり、セキュリティーが強化されているWindows 10を推奨する。
29） https://www.sumatrapdfreader.org/free-pdf-reader.html
30） 32ビット版では動作チェックしていないためである。
31） https://www.ms.u-tokyo.ac.jp/~abenori/soft/fortex.html
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2. PCの電源を入れ、パスワードを入力してサインインする。
3. 実習に使用している Windows 機（日本語キーボード）がたまたま英語モードになっていると、
キーボードに刻印された文字が入力できなくなる。そういう場合は、コントロールパネルの “言
語” または “Language” で “日本語” を選択してから一番上に移動する。

4. スタートボタンを右クリックし、エクスプローラーを表示する32）。
5. エクスプローラーの右上隅の ∧ をクリックし、リボンの表示・非表示を切り換えてみる。
6. ［表示］をクリックする。
7. 左端の「ナビゲーション ウィンドウ」で▼を左クリックし、“ナビゲーション ウィンドウ” を
チェックする33）。

8. 「ペイン」上で “プレビューウィンドウ” と “詳細ウィンドウ”（トグル）を非選択とし、「レイ
アウト」上で “詳細” を選び、「表示/非表示」の上で “ファイル名拡張子” をチェックする。

4.3 実習用フォルダーの解凍と移動

筆者は 2015 年度以来、本文書に記した実習を年に数回実施しており、その都度、チュートリアル
を改訂してきた。実習にはWindowsあるいはmacOSの PCを使う。Windows用のインストーラー
であることを明示するために、配付ファイル名は Win_exercise.zip、インストーラーのフォルダー
名はWin_exerciseとしてある。

1. 今回の実習で使用するすべてのフォルダーとファイルは、サインインしたユーザーのホームフォ
ルダー、すなわち C:UUsersU(ユーザー名) の下に置かれている。エクスプローラーでホーム
フォルダーを開く。

2. ホームフォルダーにWin_exercise.zipとWin_exerciseフォルダーが存在していたら削除する。
3. Win_exercise.zipをホームフォルダーにコピーする。
4. Win_exercise.zip を右クリックして「すべて展開」を選び、“完了時に展開されたファイルを表
示する” のチェックを外し、展開先のフォルダーの絶対パスから最後の “Win_exercise” を削除
した後、解凍する34）。

5. 念のために生成した Win_exercise フォルダーを右クリックしてプロパティを選び、その置き場
所がホームフォルダーであることを確認する。

6. Win_exercise フォルダーが本文書 (Win_exercise.pdf) に加えサブフォルダー cryscalc,
Dysnomia, EDMA, Fox, gnuplot, PyAbstantia, superflip, VESTA, Windows_versions, win-
plotr_package35）を含んでいることを確認する。

7. 今回の実習で作成するグラフはすべて gnuplotUbinUgnuplot.exe によりバッチモードで作画さ
れ、pdfcairoターミナル、すなわち PDFファイルに出力される。

32） Windows 10 のエクスプローラーを使用する場合の操作を以下に記す。なおエクスプローラーの利便性が今一つなの
で、筆者は秀丸ファイラー Classicを使っている。GUIがWindowsのバージョンに依存せず、表示フォルダーをタブ切り
替えできる点が秀逸である。

33） ファイル操作にはホームメニューを使う。
34） “Win_exercise” を削除しないと、そのフォルダーが二重になってしまう。Lhaplusのような圧縮・解凍ソフトをイン
ストール済みの場合は、そちらを使用してもよい。

35） WinPLOTR はその Web ページ末尾の記述に従い、民間企業の方が今後も使用する場合は作者に直接コンタクトされ
たい。
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図 4 ダウンロードしたファイルの実行時に表示される
ことがある SmartScreenの警告ダイアログ。

4.4 インストール

1. 実行中のアプリケーションがあったら、終了しておく。
2. 旧バージョンのプログラムをインストール済みだったら、念のために Windows_versions フォ
ルダー中の Uninstall_RIETAN_VENUS.batを右クリックして「管理者として実行」を選び、
ユーザーアカウント制御36）(User Account Control: UAC) の下で旧バージョンをアンインス
トールしておく。

3. 同じフォルダー中のハンズオン用インストーラー Install_RIETAN_VENUS.bat を右クリック
して「管理者として実行」を選び、ユーザーアカウント制御の下で全プログラムと実行例などを
Cドライブにインストールする。上記の警告には同様に対処する。

PCの設定によっては、アンインストール・インストール時に「Windowsによって PCが保護され
ました」というWindows Defender SmartScreen の警告ダイアログ (図 4)が現れることがある。ア
プリケーションを実行しようとすると、アプリケーションの安全性を確認して PCを保護する仕組み
である。その際には「詳細情報」をクリックしてから、[実行]をクリックすればよい。
Mac の Parallels Desktop + Windows 仮想環境上で RIETAN-FP・VENUS システムをインス
トールする際の注意点については、2015年 3月 21日のブログエントリー「Parallels Desktop 10 +
Windows 8.1 における RIETAN-FP・VENUS システムのインストールとアンインストール」を参
照されたい。

4.5 インストールされたプログラムと実行例の確認、登録、初期設定

1. C:UProgram Files フォルダーの中に EDMA, Fox, gnuplot, Hidemaru, RIETAN_VENUS,
superflip, VESTA, winplotr_packageというサブフォルダーが存在することを確認する。

2. 実行例を収めたフォルダー RIETAN_VENUS_examples がユーザーのホームフォルダーにコ
ピーされたことを確認する。

36） “このアプリがデバイスに変更を加えることを許可しますか？” という問いに［はい］をクリックする。
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3. Hidemaru フォルダーに RIETAN-FP・VENUS 支援環境のプラットフォームとなる秀丸エ
ディタと秀丸マクロの機能を拡張するための 64 ビット版ダイナミックリンクライブラリー
DengakuDLL.dll37）(511 KB)が入っていることを確認する。

4. Hidemaru.exe をタスクバーにドラッグ＆ドロップしてピン留めする。以後、秀丸エディタで複
数のファイルを開いているときは、マウスのポインタをそのアイコンの上に移動するだけで開い
ているファイルを選択できるようになる。

5. C:UProgram FilesUSumatraPDFUSumatraPDF.exe を起動する。
6. 「≡（左上）> 設定 > 詳細設定」で設定ファイルを開き、‘ReuseInstance = true’とする。
7. 「≡ > 設定 > オプション」で “タブを使う” をチェックし、タブの増え過ぎを防ぐために “開
かれたファイルを記録する” のチェックを外す。

8. Adobe Acrobat Readerではオープンされているファイルが排他ロックされる（同名の最新ファ
イルを入力・表示できない）ため、Sumatra PDFを使用すると説明する。

9. VESTAを実行し、「Edit > Preferences」で “Start-up search for bonds” のチェックを外す38）。
そう設定した方が本実習に都合がよいためである。

10. VESTAを終了する。
11. RIETAN_VENUS_examples フォルダーをエクスプローターのお気に入り39）にドラッグして
登録しておくと、以後の実習に都合が良い。

4.6 RIETAN_VENUSフォルダーのチェック

1. RIETAN_VENUS フォルダーの中身を眺めて、どんなファイルやフォルダーが入っているかを
簡単に説明する。Dysnomiaのプログラムとデータファイルはこのフォルダーにコピーした。

2. Macrosフォルダーには RIETAN-FP・VENUS統合支援環境用の秀丸マクロ ∗.mac、Commands
フォルダーには bashスクリプトを実行するための bash.exe（4.7.3参照）、秀丸マクロ内で実行
する bash スクリプト ∗.command、PDF ファイル編集用ユーティリティー qpdf 一式を収めた
フォルダーが入っている。

3. Commands フォルダー中の任意の ∗.command を右クリックしてプロパティを選んだときに
「プログラム」が BusyBox multi-call binaryになっていない場合は、[変更]をクリックしてから
CommandsUbash.exeに関連付けた後、[適用]をクリックする40）。

4. TEX 関係の bash シェル、すなわち cif2pdf.command, E2J.command, Typeset.command,
BibTeX.command, MakeIndex.commandでは

PATH="C:/texlive/2020/bin/win32;C:/texlive/2019/bin/win32;\

C:/texlive/2018/bin/win32;C:/texlive/2017/bin/win32;${PATH}"

というようにパス指定している。TeX Live 2020/2019/2018/2017以外をインストールしている

37） 64ビット版Windows 10上では 64ビット版の DengakuDLL.dllを使わないと、秀丸マクロの実行直後に出力ファイ
ルが自動表示されないことがある。

38） ユーザー環境変数 VESTA_PREF で定義したフォルダー中の設定ファイル default.ini に記録されている最大原子間
距離を必要に応じて修正すれば、作画・削除すべき結合を調整できる。プロットしたくない結合は最大距離をゼロにしてお
くとよい。

39） Windows 8.1以前の呼称。Windows 10では「クイック アクセス」。
40） 原因は不明だが、秀丸マクロで生成した ∗.commandが BusyBox multi-call binaryに関連付けられないことがまれに
ある。そのような場合も同じ措置をとる。
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場合は、年号の部分を変更しなければならない。
5. RIETAN_VENUSUdocuments フォルダーの中にはソフトウェアのマニュアルなどが置かれて
いる。同フォルダー内の任意の PDF ファイルを右クリックしてプロパティを選んだときに「プ
ログラム」が Sumatra PDF になっていないならば、[変更] をクリックしてから C:UProgram
FileszUSumatraPDFUSumatraPDF.exe に関連付けた後、[適用] をクリックする。こうしてお
けば、hoge.plotと hoge.gpdから gnuplotが作成した PDFファイルが自動的に Sumatra PDF
で開かれる。

6. Ctrl +W を押して RIETAN-FP_manual.pdfを閉じる。

4.7 RIETAN-FP・VENUS統合支援環境のセットアップと基本機能

4.7.1 実習手順
1. タスクバー上の秀丸エディタのアイコンをクリックして秀丸エディタのウィンドウを表示する。
2. 「その他 >設定内容の保存/復元41）」で設定内容の保存/復元ダイアログ（図 5）を開き、“設定
情報をファイルから復元する” と “現在の設定をリセットしてから復元” をチェックした後、
[次へ >>] をクリックする。

図 5 設定内容の保存/復元ダイアログ。

3. RIETAN-FP・VENUS 統合支援環境用設定ファイル RIETAN_VENUSUMacrosURIET-
AN_VENUS.hmereg を開くと、それに保存されている設定情報がレジストリに書き戻さ
れる。

4. 秀丸エディタヘルプのウィンドウが前面に現れるが、今は参照する必要がないので閉じておく。
5. LATEX文書組版用マクロ cif2pdf, Typeset, BibTeX, MakeIndex（7.2参照）を利用する場合は、
「その他 > 動作環境 > 関連付け」で拡張子 con, ilg, refを秀丸エディタに関連付けることを推
奨する。それらのマクロでは、プログラムを指定せず open 命令によりテキストファイルを開く
ためである。

41） Alt + O + U でもよい。Parallels Desktop＋Windowsの場合は option + O + U 。

11



行番号表示
/非表示

アウトライン解析の枠

ファイル
マネージャ枠

図 6 ツールバーの中心付近に置かれている 5 つのボタン。
ファイルマネージャ枠を表示しているときのスナッ
プショット。

6. 「その他 > 動作環境 > 関連付け」で［スタートメニュー等への登録］をクリックし、“コンテ
キストメニューの直下に「秀丸エディタで開く」を入れる” をチェックしてから Windows を再
起動すると、ファイルを右クリックし「秀丸エディタで開く」を選べるようになる42）。

7. RIETAN_VENUS_examplesUFapatiteUFapatite.ins を開き、ツールバー上のボタン［行番号
表示/非表示］、［アウトライン解析の枠］、［ファイルマネージャ枠］（図 6）の上にカーソルを移
動し、各ボタンの名称を表示してみる。いずれも表示・非表示がトグルになっている。

8. アウトライン解析43）の枠を表示する。最初の文字が ‘!’ であるしおりが行頭のスペース数 (0, 2,
4)に対応した形でツリー表示される（図 7）。ツリーは折りたためる。

9. どれか一つのしおりをクリックすると、当該しおりの行がテキストエリアの中心付近に茶色で表
示される。アウトライン解析の枠を消す。

10. 行番号を表示し、消す。
11. ファイルマネージャ枠を表示し、同枠上部で Fapatite フォルダーを選択すると、同フォルダー
内のファイルすべてが下部に表示される。

12. テキストファイル、たとえば Fapatite.lst をダブルクリックすると、秀丸エディタでそれを開け
る44）（図 8）。秀丸エディタ以外のアプリケーション（たとえば VESTA）で開きたいときは、
ファイルを右クリックして「プログラムから開く」を選び、プログラムを選択する。

13. ファイルマネージャ枠からシェルスクリプト ∗.command を実行するには、ファイルを右クリッ
クして「プログラムから開く」を選び、プログラムとして BusyBox multi-call binary (bash.exe)
を選ぶ。

14. ファイルマネージャ枠で可能なファイル・フォルダー操作は次の通り。

•ファイルを選択し Ctrl + C 、 Ctrl + V を押して同一フォルダーにコピーする。たとえば
Fapatite.insは Fapatite - のコピー.insという名でコピーされる。

•ファイルを選択し Ctrl + C を押した後、他のフォルダーを選択してから Ctrl + V を押し
てそのフォルダーにコピーできる。

•ファイルを右クリックして削除する。
•ファイルを右クリックして “切り取り” を選び、他のフォルダーを選択してから Ctrl + V
を押してそのフォルダーに移動する。

42） RIETAN_VENUS.hmeregには記録されない。
43） 特定の記号（本支援環境の場合 ‘!’）が行頭に存在しているならしおりと解釈する。
44） テキストファイルは秀丸エディタで開けるが、実行形式ファイルのダブルクリックでそれを実行できるわけではない。
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図 7 テキストウィンドウの左側にアウトライン解析枠を表示した秀丸エ
ディタで、‘! Real chemical species’ というしおりをクリックし
たところ。Select ブロックと If ブロックの構文がそれぞれ赤と青で
表示されるのは、強調表示を登録したためである。

図 8 Fapatite.lst を表示しているテキストウィンドウの右側にファイルマネー
ジャ枠を引き出した秀丸エディタ。

•フォルダーを右クリックし「開く」を選ぶと、そのフォルダーを表示したエクスプローラー
のウィンドウが現れる。ファイルを改名する際に利用するとよい。

ファイルマネージャ枠を開いた後、表示しているフォルダー内に変更があると、ファイルマネー
ジャ枠同期マクロ filemng_sync.macによりファイル一覧が自動更新される。

15. ファイルマネージャ枠のデフォールト表示は “フォルダ＋ファイル一覧” となっているが、▼を
クリックして “ヒストリ” を選ぶと、過去に開いたファイルの一覧が現れる。
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16. ［マニュアル］をクリックして RIETAN-FP_manual.pdf を開く。「≡ > 表示 > ブックマー
ク」を選んでブックマークを表示する。

17. いくつかの章にジャンプしてみる。末尾に RIETAN-FP に追加した新機能に関する日本語情報
が付属していることを指摘する。

18. RIETAN-FP_manual.pdfを閉じる。
19. ファイルマネージャ枠を消す。

4.7.2 支援環境に関する補足
マクロのプルダウンメニューからすべての秀丸マクロを選べるが、比較的使用頻度の高いマクロに
はツールバーやステータスバー（F1〜F10）上にボタンが割り当てられており、クリックするだけで
秀丸マクロを実行できる。さらに shift あるいは Ctrl を押すと、ファンクションキーが他のマクロ
に切り換えられる45）。このようなボタンのクリックによるマクロの実行が秀丸エディタの大きな利
点である。 Ctrl + E を押すと現れるポップアップメニューからもマクロを選べる。
CIF コンバーター cifconv、第一原理計算用マクロ VASP, 誘導構造導出用マクロ supercell の詳
細については、cifconv_man_Win.pdf と「CIF を出発点とする第一原理計算支援用ユーティリ
ティー」 [22]を参照されたい。

図 9 使用頻度が低いマクロを実行する
ためのポップアップ・メニュー。

ポップアップ・メニュー（図 9）でも 10 個の秀丸マク
ロを選択できる。ショートカット用アルファベットが左
側に表示されている。xdc は特定元素の X 線分散補正項
と質量減衰係数をグラフ化するのに使う (5.4.5)。xml2bgr
については 5.3.3 を、R_indices については 5.7 を参照せ
よ。listPPP は一次プロファイル・パラメーター (Primary
Profile Parameter: PPP)の 2θ 依存性を Igor Proでグラ
フ化するためのユーティリティーである (5.4.6)。分割プ
ロファイル関数を利用する際、物理的に意味のある PPP
に収束したか否かをチェックするのにとりわけ役立つ。
Dysnomiaは後述するMPF解析 (5.12)と異なり、MEM解
析を一回だけに留める MEM/リートベルト解析を実行する
のに使う。MADEL はマーデルング・エネルギーと各サイ
トの静電ポテンシャルを計算するためのプログラムであり、イオン間の静電相互作用を見積もれる。
DICVOL14 は二分法による指数づけのプログラム DICVOL の最新版である (5.1.3)。Bond valence
parametersを選択すると bond valence sum（6節）を計算するためのパラメーターを収録した CIF、
bvparm2016.cif を閲覧できる。ffe2ins は個々の幾何学的パラメーターに抑制条件 (restraint) を付加
するのに用いる (5.10.3)。C-Toolsは DFTコードの入力ファイル作成用補助ツールである [22]。
使い勝手を改善するためキー割り当てやポップアップ・メニューなどを変更する際には、

Readme_macros.pdfの付録中の

1. ユーザーメニューへのマクロの登録キー割り当て、
2. マクログループとマクロへのキーの割り当て、

45） ただし、Parallels Desktop＋Windows 10では、それぞれ control＋⌘ (または control＋ shift )と shift＋⌘（ま
たは shift＋ control ）を押さなければならない。二つ目のキーは押さずに叩く（指を離す）こと。
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3. キー割り当ての解除、
4. ツールバーにおけるマクロのアイコンの表示

を読むとよい。ポップアップメニューへのマクロの登録については、Evernote の公開ノート「ポッ
プアップメニューにマクロを登録する」も参考になる。RIETANや Plotのような頻繁に実行するマ
クロにはショートカットを割り当てておくと利便性が高まろう。
しおりは「その他 > ファイルタイプ別の設定 > ファイルタイプの設定」で拡張子を指定した後、
設定の対象として「アウトライン」を選んで「アウトライン解析の枠」をチェックし、さらに「アウ
トライン」の下の「解析」を選んで定義する。必要に応じて既存の設定を変更し、新たな設定を追加
することによって自分の環境用にカスタマイズすれば、利便性が一層高まる。
上述のように、hoge.ins がカレントファイルの場合はスペースを除く先頭文字が ‘!’ の注釈行を
しおりとみなす。さらに RIETAN-FP・VENUS システムの入出力ファイルのうち、拡張子が lst
(RIETAN-FP), dst (ORFFE), cif (lst2cif), inflip (RIETAN-FP)のテキストファイル46）でも、アウ
トライン解析枠でしおりが見られる。ただし ‘!’ の位置で段付けをコントロールできる hoge.ins と異
なり、しおりは階層化されない。

4.7.3 BusyBox — 圧縮の極致
秀丸マクロから実行されるシェルスクリプト RIETAN_VENUSUCommandsU∗.command では

grep, sed, awkに代表される UNIXコマンドを駆使しており、bashシェルによるテキスト処理のテ
クニックを学ぶのにも役立つ。
これらの UNIX コマンドは UNIX シェル RIETAN_VENUSUCommandsUbash.exe に内包され
ている。Windows 用 RIETAN-FP・VENUS システムでは、bash スクリプトを実行するための
バックエンドとして bash.exe を利用している。bash.exe は 64 ビット組み込み UNIX プログラム
busybox64.exe を改名したものに他ならない。その bash.exe (別名 BusyBox multi-call binary) に
bashスクリプトを関連付けるだけで、Windows用 BusyBoxのWebサイト中の画面キャプチャーに
表示されている全 UNIXアプレット（コマンド）を bashスクリプト中で使えるようになる。
bash.exe のダブルクリックにより現れる bash ウィンドウ47）や bash.exe に関連付けられた bash
スクリプトでは、上記のアプレットがパスを通さずに実行できる48）。BusyBox が内包する bash の
実体は POSIX互換の小型シェル ashに過ぎないものの、UNIX用の bashスクリプトは「シェルス
クリプト基本リファレンス」 [23] を参照すれば、わずかな変更で BusyBox の bash 用に書き換えら
れる。このような利便性の高さは bash.exe のサイズが 700 KB 足らずであることを考慮すると、驚
嘆に値する。さらに、bash.exeはWindows 10限定のWindows Subsystem for Linux (WSL)と異
なり、Windows 7 以降の OS でインストール作業なしに使える。Windows 用 BusyBox の詳細につ
いては、Evernoteの公開ノート「Windows 用 BusyBox について」を参照せよ49）。
たとえば RIETAN-FP実行用の秀丸マクロ RIETAN.macでは、

runsync2 "¥"C:¥¥Program Files¥¥RIETAN_VENUS¥¥Commands¥¥bash¥"

¥"C:¥¥Program Files¥¥RIETAN_VENUS¥¥Commands¥¥RIETAN.command¥"

46） カッコ内はそれぞれのファイルを出力するプログラムを意味する。hoge.inflipは superflip用入力ファイルである。
47） 窓の名前は C:UProgram FilesURIETAN_VENUSUCommandsUbash.exeとなっている。
48） コマンドの記述法については、https://busybox.net/downloads/BusyBox.html を参照せよ。bash ウィンドウで
コマンド名 --helpと入力するという手もある。

49） Shift_JISのダメ文字（“ソ噂欺圭構蚕十申箪貼能表暴予禄兔饅”など）を sedにより置換する技まで記載してある。
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¥"" + dllfuncstr("GSUB", filename2, "¥¥", "/", -1) + "¥"";

というように bash スクリプト RIETAN.command を引数として bash.exe を実行する。メタ文字
“U”は “U”でエスケープし、田楽 DLLの関数 dllfuncstr(.....)では bashスクリプトに絶対パ
スを渡すために絶対パス中の “U” を “/” で置換する。RIETAN.command の引数は絶対パス付きの
カレントファイル（秀丸エディタの前面で表示されているファイル）の名前である。すると bash
ウィンドウが現れ、その中で RIETAN.command が動き出し、標準出力がウィンドウ内に表示され
る。bash ウィンドウのサイズ、位置、フォントサイズなどは bash.exe をダブルクリックして bash
ウィンドウを開き、左上のアイコンをクリックして「プロパティ」を選んでから設定する。
Pythonスクリプト中で bashスクリプトを実行する場合も、絶対パス付きの *.commandを引数と
する。近年、絶大な人気を誇っている Python との連携はシェルスクリプトに新たな付加価値を与え
るだろう。

5 RIETAN-FP・VENUSシステムと外部プログラムの実行

5.1 WinPLOTRによるピークサーチと指数付け

WinPLOTR [6] は粉末回折データを解析するための Windows 用グラフィックツールである。
WinPLOTRについては Evernoteの公開ノート「RIETAN-FPとWinPLOTRとの連携」に詳述し
たので、必要に応じて参照せよ。

5.1.1 Fapatite.intの処理
1. 秀丸エディタで Fapatite.ins を表示している状態で［WinPLOTR/int］ (F1) をクリックし、

WinPLOTRで回折パターンを表示する。
2. カーソルの位置に応じて 2Th (2θ)、d（格子面間隔）、Y（回折強度）の値がリアルタイムで変
わることを指摘する。

3. 「Points Selection > Automatic peak search」を選ぶ。比較的弱い反射を検出するため “Peak
threshold” を 0.01に減らし、“Search Cu Ka1/Ka2 doublets” をチェックしてから［OK］をク
リックする。

4. “81 peaks have been found” というメッセージが出力され、Automatic peak search resultsの
ウィンドウが（背後に）現れる。

5. 「Points Selection > Save as ... > Save points for DICVOL06」を選ぶ。Titleを Fluorapatite
とし、結晶系として hexagonal をチェックしてから［OK］を 2 回クリックして DICVOL 用入
力ファイル Fapatite.dic を保存してから、[いいえ] と [はい] を順番にクリックして DICVOL06
を実行する（図 10）。引き続き［OK］と［Kenavo50）!］を順番にクリックする。

6. 秀丸エディタのファイルマネージャ枠を表示し、計算結果の出力ファイル Fapatite.indを開き、
反射の回折指数 hkl51）、d と 2θ の観測値と計算値を確認する。線形最小二乗法で精密化した六
方晶系の格子定数 a と c は後にリートベルト解析を実行する際、初期値に用いる。

7. WinPLOTRに戻り、「File > Reset」で入力・処理済みのデータを消去する。

50） ブルターニュ地方の言語であるブルトン語で「さようなら」を意味する。
51） ブラッグ反射の指数 hkl を (hkl)と誤記するのは、結晶学に疎い人にありがちなミスである。これについては 2013年

5月 1日のブログエントリー「格子面と反射の表記法について」を参照せよ。
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図 10 WinPLOTR でフッ素アパタイトの粉末 X 線データからピーク位
置を求め,内蔵の DICVOL06で指数づけしたところ。

8. 「Tools > Space groups info」でフッ素アパタイトの空間群 P63/m の番号 (176)を入力し、空
間群に関する情報を表示するウィンドウが現れることを説明する52）。

9. 「Tools > hkl list generation」で格子定数、波長、2θmin、2θmax、空間群を入力すると、hkl,多
重度 m, d, 2θ などを表示するウィンドウが生成する。

リートベルト解析やパターン分解では格子定数の初期値がとりわけ収束し易さを左右する。初期値
が真値から離れていると、観測プロファイルに対する計算プロファイルのフィットが悪化し、解が発
散したり偽の極値に落ち込みかねない。分解能の高い回折データでは、そういう傾向がなおさら顕著
になる。急がば回れで、あらかじめ指数づけプログラムでピーク位置から格子定数を精密化しておく
ことを推奨する。とくに CuKα 特性 X線で測定した強度データの場合 Kα1 ピークの位置が求めに
くいので、指数づけが役立つ。

5.1.2 反射の追加
ピークサーチで一部の反射が検出できなかったならば、次の操作で追加する。

1. 2Th を見ながら、検出されなかった反射の近傍の 2θ 範囲をマウスドラッグで拡大表示する。
「Points Selection > Add peaks/background points」を選ぶと追加モード入りし、＋のカーソ
ルが現れる53）。そのカーソルを移動し、検出に失敗した反射を左クリックで追加する。

2. 反射の追加が終わったら、ウィンドウ内で右クリックして追加した反射を確定すると、追加
モードから脱け、＋のカーソルが見えなくなる。拡大表示のまま「Points Selection > Add (or
Remove) peaks/background points」を選んで反射やバックグラウンドの追加・削除を続行でき
るが、さらにもう一回右クリックすると回折パターン全体の表示に戻る。

52） WinPLOTRでは、サイズの小さいウィンドウがメインウィンドウの背後に隠れ、現れないと誤解することがある。
53） ＋のカーソルが見えている状態では回折パターンの拡大・縮小はできない。
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5.1.3 DICVOL14について
DICVOL06 の代わりにそのアップグレード版 DICVOL14 を使うこともできる。WinPLOTR で

DICVOL06 用入力ファイル hoge.dic をカレントフォルダーに出力してから秀丸エディタに戻り、
Ctrl + E を押してポップアップ・メニューを出した後、“DICVOL14” を選ぶ。上述のように計
算結果は hoge.ind に出力される。DICVOL06 による指数づけが失敗に終わったら、試してみると
よい。DICVOL14の実行形式プログラム DICVOL14.exeは C:UProgram FilesUwinplotr_package
フォルダーに入っている。
DICVOL14 に関する論文 [5] は以前、オープンアクセスとなっており、Windows 用 DICVOL14
のアーカイブファイルへのリンクも含まれていた。dicvol14.exeはそこから入手した。

5.2 WinPLOTRによるバックグラウンドの見積もり

5.2.1 バックグラウンドの決定と hoge.bgrへの出力
1. 秀丸エディタで［WinPLOTR/int］(F1) をクリックして、回折強度を再表示する。「Points

Selection > Automatic background」を選び、［OK］をクリックする。25◦〜42◦の 2θ 範囲を
マウスドラッグで拡大表示する。

2. バックグラウンド強度を表す緑の丸が大きすぎると感じたら、Evernoteのノート「RIETAN-FP
とWinPLOTRとの連携」中の 13節を参照してサイズを変更する。

3. 33.4◦ 付近のバックグラウンドは明らかに高すぎる（図 11）。その点を削除するには、マウスの
左ボタンを押しながらドラッグしてパターンの一部をさらに拡大表示し、「Points Selection >

Remove peaks/background points」を選択し、不要な点の上で左クリックする。削除し終わっ
たらウィンドウ内で右クリックすると、削除モードから脱け＋のカーソルが見えなくなる。

4. バックグラウンドを追加するには「Points Selection > Add peaks/background points」を選び、
適切と思われる位置で左クリックする。

5. バックグラウンドの追加が終わったら、ウィンドウ内で右クリックして追加バックグラウンドを
確定すると、＋のカーソルが見えなくなる。さらにもう一回右クリックするとパターン全体の表
示に戻る。

6. こうして決定した離散点のバックグラウンド強度をファイルに保存するには、「Points Selection
> SaVe background points」54）を選ぶ。“Save background points ?” に対し［はい］をクリッ
クし、RIETAN_VENUS_examplesUFapatiteUFapatite.bgr を保存する55）。

7. 秀丸エディタのファイルマネージャ枠で Fapatite.bgr をダブルクリックし、眺めてみる。
Fapatite.bgr がファイルマネージャ枠に表示されないときは、フォルダ一覧ペインで Fapatite
を左クリックすればよい。

8. WinPLOTRを終了する。

バックグラウンドを削除や追加した後、右クリックして削除・追加モードから抜けると、バックグ
ラウンドのウィンドウに反映される56）。その内容は秀丸エディタのウィンドウにコピー・ペースト
できる。カレントフォルダーに既存の hoge.bgrがあっても、秀丸エディタで hoge.bgrとして重ね書

54） ‘V’が大文字になっている理由は不明である。
55） カレントフォルダーに Fapatite.bgrがすでに存在する場合は、既存データの後ろに新ブロックが追加される。バックグ
ラウンドのウィンドウはそのまま残るが、バックグラウンドは表示されなくなる。

56） 同時にマーカーのサイズは元通りになってしまう。
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図 11 フッ素アパタイトの粉末 X線回折データを入力し、バックグラウンドを推定・
表示したところ。青い矢印の先のバックグラウンドを削除し、再指定する。

きすれば、単一ブロックの hoge.bgrが得られる。
FOXでバックグラウンドのオブジェクトを作り、hoge.bgrを importすると、グラフ表示できる。
バックグラウンドの点数は変えられないが、値は変えられる。点数を変えるときは、hoge.bgrを秀丸
エディタで編集した後、同一のオブジェクトで importし直す。

5.2.2 hoge.bgrの hoge.bkgへの変換
一般にデバイ–シェラー光学系やダイヤモンド・アンビルで測定したデータや無定形物質を含む試
料のデータでは、バックグラウンドが高まり、しかも複雑にうねるのが常である。しかも高角領域で
は反射が混み合う上、熱散漫散乱57）（Thermal Diffuse Scattering: TDS）が顕著になるため、バッ
クグラウンドのレベルが不明瞭になる傾向がある。バックグラウンド・ファイル hoge.bkgを用意し、
しかも複合バックグラウンド関数を用するのがバックグラウンドを適切に表現するのに役立つ。離散
点のバックグラウンドを含む hoge.xmlまたは hoge.bgrをカレントフォルダーに保存しておけば、

1. hoge.ins中で NRANGE = 2または 3と設定されている。
2. 全観測点のバックグラウンド強度を記録したファイル hoge.bkg がカレントフォルダーに存在し
ない。

3. (a) FOXが出力した hoge.xmlあるいは (b) xml2bgrにより hoge.xmlから変換した hoge.bgrが
カレントフォルダーに存在する。

という 3 条件がすべて成立する場合に限り、RIETAN-FP は hoge.bgr 中の離散バックグラウンド強
度を補間することにより hoge.bkg （全回折点のバックグラウンド強度を記録したファイル）を自動
的に作成する。リートベルト解析結果（たとえば等方性原子変位パラメーター B）が合理的な値に
なるように hoge.bgr 中のバックグラウンド強度を調節するのも、時には有効だろう。複合バックグ
ラウンド関数を使う場合、Rwp が精密化するバックグラウンド・パラメーターの数に応じてどのよ

57） 熱散漫散乱の強度は d2 に反比例する。
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うに変化するかを調べて直交多項式の次数を決めるといいかもしれない。

5.3 バックグラウンドの見積もり、ピークサーチ、指数付け、空間群の探査

FOX [6] は粉末回折データからレプリカ交換法 (parallel tempering) あるいは焼きなまし法
(simulated annealing) により未知構造を解析するための直接空間法プログラムである。本実習では
cimetidineの構造モデル構築（5.10.1参照）に FOXを使うが、FOXはWinPLOTRと同様に、粉末
回折データを解析するための前処理グラフィックツールとしてもすこぶる役立つ。5.1 や 5.2 と重複
することになるが、パターン分解やリートベルト解析に先だつデータ処理、すなわちバックグラウン
ドの推定、ピークサーチ、指数づけへの応用を以下に述べておく。

5.3.1 FOXの初期設定
1. FOXをタスクバーに登録する。
2. タスクバー上の FOXをクリックし、“About Fox” のウィンドウで［OK］をクリックする。
3. 「Preferences > Preferences」を選び、次の項目をチェックまたはアンチェックする58）。

✓ Crystal:Default-dispay atom names in 3D view

✓ Crystal:Default-use Dynamical Occupancy Correction

✓ FOX:CIF import: automatically convert to molecules

✓ FOX:CIF import: only one scattering power per element

　 FOX:Use compressed file format (.xml.gz)

　 FOX:Use compressed file format (.xmlgz)

✓ FOX:Enables tooltips

✓ PowderPattern:Automatically open powder pattern graph

4. ［OK］をクリックする。

5.3.2 hoge.xyの処理と hoge.xmlの保存
1. Ctrl + N 59）を押し、“Crystal” の後ろに物質名（この場合 “Fluorapatite”）を入力する。
2. 「Objects > New PowderPattern」を選び、“PowderPattern” の後ろに “Fluorapatite” を入
力する。後に、これがグラフのタイトルとなる。

3. ［Data］をクリックし、“Import 2Theta-Obs Pattern” を選んで XY 形式の強度ファイル
RIETAN_VENUS_examples/Fapatite/Fapatite.xy を開く。Fapatite.xy は一般形式ファイル
Fapatite.intから最初の 2行を削除したものに相当する。

4. “Fluorapatite” をタイトルとするグラフが現れる60）。適当なサイズに拡大する。青い実線は観
測強度、赤い実線は計算強度（この段階ではゼロ）、灰色の実線は χ2 の累積値を示す。カーソ
ル位置の 2θ とカウントが最下部にリアルタイム表示される。グラフ上での左ダブルクリックで

58） FOXの開発途上版には、それを使い始めてからしばらくは Preferencesの項目が一部欠落し、使い込んでいくにつれて
項目が増えていくという不具合（仕様？）がある。たとえば 3D displayを表示したら、Preferencesに “Crystal:3D fade
distance” が現れる。全項目が表示されるようになるまでは、気長に待つしかない。

59） 「Objects > New Crystal」のショートカット。
60） 前面のウィンドウの背後に隠れているかもしれない。そうでなかったら「Objects > New Crystal」を選ぶ。
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全パターン表示に復帰する。
5. 何かのパラメーターを変更した場合は、グラフ上で右クリックし “Update” を選ぶ。
6. 左から四つ目のタブ［Phases］をクリックし、“Add Crystalline Phase” を選ぶ。“Crystal:Flu-

orapatite” が選択された状態になっている。［OK］をクリックする。
7. ［Phases］をクリックし、”Add Background (Bayesean, automatic)” を選ぶ。Davidと Sivia

(2001) が提案したベイズ推定アルゴリズムによりバックグラウンドを見積もる。バックグラウ
ンド点数を入力する。この場合は 20のままでいいが、バックグラウンドが複雑な場合は 30〜40
に増やす。［OK］をクリックするとグラフ中の赤線がバックグラウンドまで上昇し、FOX のダ
イアログボックスの下方にバックグラウンドの表が現れる。

8. ［Radiation］をクリックし、“X-Ray Tube Cu Ka12” を選ぶ。ただし FOXでは CuKα 特性
X 線の “Wavelength” を 1.539 に変えてから Enter を押さないと、指数づけで求めた格子定
数が a = 9.386Å, c = 6.897Åという大き過ぎる値になってしまう61）。1.539を入力しただけで
は、その値に更新したとみなされないことに注意せよ。

9. 粉末回折パターン上で右クリックし “Find peaks” を選ぶと、指数づけに使う低角反射 20 本の
#番号、2θ、d が現れる。グラフを右クリックして “Hide peaks” と “Show peaks” を選ぶこ
とにより非表示・表示を切り換えられる。バックグラウンドを引いた強度が赤い実線で表示さ
れる。

10. グラフ上で右クリックして “Update” を選んでグラフを再表示する。バックグラウンド曲線が
復活する。グラフのウィンドウを消してから、「Pattern > Show graph」でも再表示できる。

11. グラフ上で右クリックして “Save peaks” を選ぶと、ピークの d/Å, ∆d/Å, Io をファイルに保
存できる。

12. マウスの左ドラッグにより 2θ < 60◦ の領域を拡大する（図 12）。その際、最高の表示強度も調
節するが、ドラッグする矩形の下部がグラフからはみ出ないようにする。マウスのスクロールボ
タンを回すかトラックパッドで二本指を上下になぞれば、左右方向に沿った拡大・縮小が可能で

図 12 FOXでフッ素アパタイトの粉末 X線回折パターンの低角反射 20本を検出し
た後、2θ < 60◦ の領域を拡大表示したときのスナップショット。最下部の
バーにカーソル位置の 2θ, カウント、格子面間隔 d が表示される。

61） macOS版 Foxでも return を押す必要がある。
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ある。矢印キーを押せばグラフを移動できる。
13. 疑わしいピークは緑の文字（マーク）を右クリックして “Remove peak” を選んで除く。逆に
“Add peak” も選べる。ただし、低角領域の 20 本の反射だけが指数づけに使われることに留意
せよ。

14. グラフ内で右クリックして “Index !” を選ぶと、Fox cell Explorer のウィンドウが現れる。
DICVOLと同様の体積二分アルゴリズム (volume dichotomy algorithm)による指数づけへと移
行する。

15. ［Advanced］をクリックし、“Hexagonal” をチェックした後、［Find Cell!］をクリックする。
最高スコア 28.0の a = 9.369Å, c = 6.885Åが正しい解である。

16. 適切な解が求まらないときは、1〜3 つの余計なピークを除き、1〜3 つのピークを追加した後、
再び指数づけを試みる。

17. 正しい格子定数を選択し、［Choose crystal to apply selected cell to］をクリックし “Crys-
tal:Fluorapatite” を選んで［OK］をクリックしてから “Automatic Profile Fitting (Le Bail)”
をチェックすると、指数づけに使った 2θ領域を対象とする Le Bail解析が始まる。Le Bail解析
で除外された 2θ 領域では赤い実線がゼロになるため、段差が生じる。

18. 収束すると、下方に Rwp と GoF が出力される62）（図 13）。
19. ［Crystals］をクリックし、精密化された格子定数が表示されていることを確認する。

図 13 FOX でフッ素アパタイトの粉末 X 線回折パターンを指数づけした後、20 本
の反射を対象に Le Bail解析を行ったときのスナップショット。

62） “Automatic Profile Fitting (Le Bail)” を再チェックし、Le Bail解析を繰り返すと、Rwp と GoF が多少改善する
可能性がある。最初の Le Bail解析の結果を再利用するらしい。
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20. Ctrl + S 63）を押し、粉末回折データの処理結果を XML形式のテキストファイル Fapatite.xml
として保存する64）。

一般に、リートベルト解析では格子定数の初期値がとりわけ収束し易さを左右する。初期値が真値
から離れていると、観測プロファイルに対する計算プロファイルのフィットが悪化し、解が発散した
り偽の極値に落ち込みかねない。分解能の高い回折データでは、そういう傾向がなおさら顕著にな
る。急がば回れで、あらかじめ指数づけプログラムでピーク位置から格子定数を精密化しておくこと
を推奨する。

5.3.3 バックグラウンド・ファイル hoge.bgrの作成
RIETAN-FPは hoge.xmlを直接入力できるため、この手続きはオプションである。

1. 秀丸エディタに戻って Fapatite.xmlを開く。
2. Fapatite.xmlに格子定数、零点シフト・パラメーター、放射線（中性子、TOF中性子、X線）、

hkl、積分強度、プロファイル・パラメーター、バックグラウンド、観測強度などが記録されて
いることを確認する。バックグラウンドは ‘<XIntensityList>’ と ‘</XIntensityList>’ で囲
まれた行に記録されている。

3. Ctrl + E を押して “xml2bgr” を選ぶ。
4. Fapatite.xml が XY 形式ファイル Fapatite.bgr に変換され、秀丸エディタによりオープンされ
る。Fapatite.bgrの各行は 2θ とバックグラウンドだけからなっている。

5. Ctrl + Q 65）を押して FOXを終了する。

5.3.4 FOXによる hoge.bgrの入力とグラフ化
FOXは注釈行のない XY形式バックグラウンド・ファイル hoge.bgrを入力し、さらにベイズ最適
化66）で改善できる。xml2bgrで作成した hoge.bgr（5.3.3参照）はその形式をもつ。

1. WinPLOTRで出力した hoge.bgrの場合は、すべての注釈行を削除し、必要なら行末を LFに変
更してから保存する。

2. Powder Diffraction タブをクリックしてから「Phases > Add user-supplied Background」を
選ぶ。

3. “PowderPatternBackground” の後ろにバックグラウンド・データの名前を入力する。
4. 「Object > Import」で hoge.bgrを入力する67）。
5. 必要に応じ「Object > Bayesian Optimization」でバックグラウンド強度をベイズ最適化で改良
する。

63） 「File > Save」のショートカット。
64） Preferencesの項目不足のためにXML形式のテキストファイルとして保存できない場合は、いったん Fapatite.xml.gz
あるいは Fapatite.xmlgz として保存した後、Preferences におけるファイル形式項目を 5.3.1 に記した通りにしてから
Fapatite.xmlとして再保存する。

65） 「File > Quit」のショートカット。
66） ブラックボックス関数のパラメータを最適化するアルゴリズム。
67） 残念ながら hoge.xmlは読み込めない。xml2bgrを作成したのは、このためである。
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5.3.5 空間群の探査
FOXには Le Bail解析により可能な空間群を列挙する Spacegroup Explorerという秀逸な機能が
ある。未知構造解析の重要なステップの一つである空間群候補の絞り込みに有効である。

1. Patternのウィンドウ上で右クリックし、“Fit profile + Le Bail extraction” を選ぶ。
2. ［Spacegroup Explorer］をクリックする。
3. ［Try all possible spacegroups - Le Bail only］をクリックする。
4. Rwp と GoF の良い順番に可能な空間群が出力される。Rwp/GoF が最良の空間群が正しいとは
限らないことに注意せよ68）。

5.4 フッ素アパタイトの粉末 X線回折データの解析

5.4.1 リートベルト解析、グラフ化、ミクロ構造評価、結晶構造の可視化
1. 秀丸エディタで Fapatite.insが表示されていることを確認する。
2. 後で Niの X線分散69）の実数項 f ′、虚数項 f ′′、質量減衰係数 (mass attenuation coefficient) σm

を波長（x1軸）とフォトン・エネルギー（x2軸）に対してプロットするために ‘NPRINT = 2’と
し、150行目に'Ni' を追加する70）:

'O-' 'P' 'Ca2+' 'F-' 'Ni' /

3. 収束の安定化のために、格子定数の初期値を DICVOL06 が出力した Fapatite.ind 中の値に変
える71）。

4. Ctrl + S を押して Fapatite.insを保存する。
5. ［RIETAN］をクリックする。
6. Fapatite.*を表示している状態で［Plot］をクリックし、gnuplot で作画したリートベルト解析
結果の観測・計算・差パターン (Fapatite.pdf)を Sumatra PDFで表示する72）。

7. 拡大アイコンをクリックして拡大表示し、グラフ全体をドラッグし、縮小アイコンをクリックし
て縮小表示する。

8. アウトライン解析の枠で Fapatite.lstのしおりを何カ所かクリックして表示してみる。
9. Fapatite.plt 中で 3 行目を ‘LPS = 1’ とする。次に 38〜43 行目を選択してから［注釈］ボタ
ン73）をクリックすることにより ‘#set title .....’と ‘#set label .....’の ‘#’を削除し、
Ctrl + S を押して Fapatite.pltを保存した後、［Plot］をクリックする。

10. ‘LPS = 1’ への変更により、リートベルト解析結果の観測・計算・差パターンの横軸（上部）に
格子面間隔 d の目盛、数値、ラベル (d/Å)が付けられる74）（図 14）。Gnuplotが出力するすべ
てのグラフ（PDF ファイル）において、ラベル、数値、タイトルにグラフ向きの sans-serif 系
フォントが使われる。

68） FoxManual, p. 44。
69） 俗に言う「異常分散」。
70） 試料に含まれない元素を追加しても実害はない。
71） 数値データは左ダブルクリックで選択できる。
72） pdfcairoターミナルに出力しているため、余白は自動的に削除され、調節も可能である。
73） トグルになっており、［注釈］をクリックするたびにプリフィクスを削除または挿入できる。
74） set link .....により 2軸を対応させるテクニックの好例である。
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図 14 Gnuplotで描いたフッ素アパタイトの X線リートベルト解析パターン。

11. グラフを見終わったら Ctrl +W を押して Fapatite.pdfを閉じる。
12. Fapatite.* のタブをクリックしてから［ORFFE］をクリックし、Fapatite.dst に全サイトの結
合距離 (3.1Å 以下) が出力されていることを確認する。Ca1・Ca2 サイトの配位数が互いに異
なっており、Ca2だけが Fと結合していることを指摘する。同一内容の Fapatite.ffeが同一フォ
ルダーに保存されている。

13. 抑制条件付加用の Fapatite.ffe がカレントフォルダーに存在する限り、Fapatite.ffe は更新され
ない。そこで Fapatite.ffe を削除してから再度［ORFFE］をクリックすると、上記の結合距離
から導出した全結合角が Fapatite.dstと Fapatite.ffe中の原子間距離の後ろに追加される75）。

14. ［lst2cif］をクリックして Fapatite.cifを作成し、その中身を説明する。
15. ミクロ歪み (microstrain) ε と結晶子サイズ D を決定するためのグラフをプロットするため、
［MSCS］をクリックする。Halder–Wagnerプロット76）はほぼ直線に乗っており、異方的なプロ
ファイル広がりが無視できるほど小さいことを示している。見終わったら、 Ctrl +W を押して
Fapatite-mscs.pdfを閉じておく。

16. 秀丸エディタで Fapatite.lst を表示し、［VESTA/lst］をクリックして VESTA に Fapatite.lst
を読み込ませることによりフッ素アパタイトの結晶模型を表示する。

17. Objectsタブをクリックした後、各サイトの ‘L’ をチェックしてサイト名を表示する。チェック
を外す。

18. 「Edit > Bonds」を選び、［New］をクリックする。Search additional atoms recursively…, A1:
P, A2: O, Max. length: 1.6Å,［Apply］, ［OK］。

19. 「Utilities > Geometrical Parameters」を選ぶと、Fapatite.ffe が読み込まれる。Interatomic
Distance タブの下でいくつかの結合距離をクリックし、球棒模型中の該当原子が選択状態にな
ることを確認する。同様に Bond Angleタブの下ですべての O–P–O結合角をクリックし、球棒
模型で三つの原子が選択されることを確認する（図 15）。

20. オブジェクトの回転（矢印アイコンをクリックしてから Tools タブ）。Drag → Animation
（Click, Push, Randomモード）。Pushの時はマウスの左ボタンを押したままにすること。最後

75） 2016年 3月 5日のブログエントリー「ORFFE による結合角と二面角の計算」参照。
76） 本実習で作画するHalder–Wagnerプロットでは、入射X線、光学系、試料内部へのX線の浸透などに依存する広がり
の寄与を差し引いていない。

25

http://blog.fujioizumi.verse.jp/?eid=308


図 15 Bond Angle タブをクリックし、フッ素アパタイトの幾何学的パラメーターを
ORFFE で計算して得られた結合角 O3–P–O1 が VESTA で表示している結晶模
型におけるどの部分に該当するかを選択表示したところ。

に Dragを選ぶ。
21. 拡大・縮小。Styleタブをクリックし、“Polyhedral” をチェックする。［Properties］をクリック
し、Polyhedraタブで Opacityをリアルタイムで変えてみる。

22. 「Ball-and-stick」をチェックする。[Properties] をクリックし、Atoms タブの「Radius and
color」で Caのサイズを 1.6に変更する。

23. ［Select］をクリックし、 Shift を押しながら複数の原子をクリックして選択し、 Delete 77）を
押して削除する。「Edit > Undo」で復活する。マウスの左ボタンを押しながらドラッグするこ
とにより複数の原子を選択できる。

24. ［Boundary］をクリックし、x, y, z の最大値を 2に変える。［Properties］をクリックし、“All
unit cells” をチェックする。

25. Ctrl +W を押して VESTAの Fapatite.lstウィンドウを閉じる。

5.4.2 リートベルト解析を始める前に励行すべきこと
リートベルト解析のような非線形最小二乗計算を順調に収束させるには、能う限り真値に近い初期
パラメーターを入力する必要がある。たとえば、hoge.bkg に記録したバックグラウンド強度は実測
バックグラウンドを十分良く表現していなければならないし、線形パラメーターである尺度因子でさ
えオーダーが大体合っていることが望ましい。本質的に重要なのは、格子定数から計算したピーク位
置が実測値にかなり近いことである。
図 14 のようなリートベルト解析パターンは、視覚に訴える形で解析の問題点を浮き彫りにする。
初期値の適否は NLESQ = 1 (Gauss–Newton 法）かつ NCYCL = 0（残差二乗和は計算するが、最小
二乗計算はスキップする）に設定した後、すべてのパラメーターを固定して RIETAN-FPを実行し、
リートベルト解析パターンをプロットすることにより容易に知ることができる。人間の目は瞬時にし
て観測パターンへの計算パターンのフィットの良否、ひいては変更すべきパラメーターが何であるか

77） Parallels Desktopあるいは Boot Campを利用する場合、 control + delete または fn + delete 。
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を察知する能力をもつ。

5.4.3 Gnuplotの更なる活用に向けて
上述のように gnuplot スクリプト・ファイル hoge.plt の一部を修正すれば、gnuplot が出力する

PDF ファイルに直接反映される。好みに応じて、線やシンボルの色と線幅、数値、キャプション、
タイトルの大きさと位置などを変えることを推奨する。Gnuplot 5全般について学ぶには文献 [9]を
読むとよい。
前述のように hoge.plt では pdfcairo ターミナルを通じてグラフを PDF ファイルとして出力する。

pdfcairoを使いこなすには 2016年 5月 25日のブログエントリー「Gnuplotで pdfcairoターミナル
を使うための手続き」が直接役立つ。gnuplot で直接 PDF ファイルを出力する技術の習得を手助け
できる。特殊文字や日本語を出力する方法も詳述されている。
なお、table コマンドで hoge.gpd 中の数値データをファイルに書き出すこともできる（Web ペー
ジ「gnuplotで数値をファイルに書き出す (table)」参照）。

5.4.4 裏技で遊ぶ
余興として、フッ素アパタイトのリートベルト解析結果の観測・計算・差パターンに含まれる線や
シンボルをももいろクローバー Z（ももクロ）のイメージカラー、すなわち

•観測強度： 赤
•計算強度： ピンク
•観測強度−計算強度： 紫
•ピーク位置： 緑
•バックグラウンド強度： 黄

でプロットしてみる。ピンクと黄色の線をくっきり見せるために背景が白から黒に変わるのに対し、
枠、目盛り、数値、ラベル、タイトルは白色で表す。

1. RIETAN_VENUSUBatch_files フォルダー中の mcz.command を Fapatite フォルダーにコ
ピーする78）。

2. mcz.commandをダブルクリックし、Fapatite-mcz.pdfを表示する（図 16）。
3. グラフを見終わったら Fapatite-mcz.pdfは Ctrl +W を押して閉じておく。
4. ファイルマネージャ枠で mcz.command をダブルクリックして開き、 UNIX 互換のストリー
ム・エディター sedを拡張正規表現 [21]モードで使用し、後述の E2J.commandと同様にその強
力な文字列置換機能を活用して色名を置換していることを説明する。

5. 緑の衣装を着ていた有安杏果は 2018 年 1 月にももクロを卒業した。そこで mcz.command 中
の "green"を "white"に変えてから保存し、ダブルクリックしてみる。ピーク位置を示す緑の
線が白くなる。

78） 時間の節約のために Fapatiteフォルダーにコピー済みである。
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図 16 mcz.commandによりプロットしたフッ素アパタイトの X線リートベルト解析
パターン。図 14の背景、線、文字の色を変更したもの。

5.4.5 Niの X線分散補正項と質量減衰係数のグラフ化
hoge.insで NPRINT = 2に設定して RIETAN-FPを実行した後、xdcマクロを選択し元素名を指定
すると、X線分散（俗に言う異常分散）の実数項 f ′ と虚数項 f ′′、質量減衰係数 (mass attenuation
coefficient) µm が波長（フォトン・エネルギー）の関数としてプロットされる。この機能は放射光だ
けでなく特性 X線でも使える。hoge.ins において純粋な化学種 (pure chemical species)として任意
の元素名をダミー入力して当該元素のグラフを描くという裏技も忍ばせた。

1. ツールバー上の秀丸エディタのアイコン上にカーソルを移動し、Fapatite.* のどれかをクリック
して秀丸エディタのカレントファイルとする。

2. Ctrl + E を押して “xdc” を選んで ‘Ni’と入力すると、f ′, f ′′の波長（フォトン・エネルギー）
依存性のグラフが現れる79）（図 17）。NiのK 吸収端 λ = 1.48807Å近傍で f ′, f ′′, µm が劇的
に変化することが一目でわかる。

3. 筆者の PCはモバイルW-iFiルーター経由ででネットにつながっているので、ワシントン大学の
Webページがブラウザーでオープンされ、吸収端のエネルギーと波長が表示される80）（図 18）。

4. f ′, f ′′, µm の波長依存性は次の 4項目を通じて理解できる。
•一般に物質によるＸ線の吸収スペクトルを測定すると、 吸収端より高エネルギー（短波
長）側で吸収が激増する。吸収が「へり」のように劇的に変化するという意味で吸収端と呼
ばれる。

•吸収端は K 殻電子のような内殻電子を外殻の空軌道に励起するのに必要なエネルギーに相
当する。

•吸収端より高エネルギー側では、電子が L 殻や M 殻から K 殻に落ちてくるとき余分なエ
ネルギーを蛍光 X線として放出する。

•xdc が出力するグラフは、たとえば CuKα 特性Ｘ線で粉末回折データを測定するとき Ni
フィルターで CuKβ 線 (λ = 1.3847Å) をカットし、Feを主成分として含む試料でバック
グラウンドが高まるといった現象の理解に役立つ。

79） 便宜上、λ > 0.4132807 Åの領域がプロットされるが、それより短波長側も事実上無制限に計算できる。
80） 講習会で Wi-Fi ルーターを通じて PC をネットに接続している場合、Firefox を規定のブラウザに設定するとともに
「設定 > ネットワークプロキシ」で “プロキシを使用しない” をチェックする。
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図 17 Niにおける f ′, f ′′, µm と波長（フォトン・エネルギー）との関係。 上下
左右に軸目盛りとラベルが付いている。y 軸に対する数値のマイナスは
set minussignコマンドで出力できる。

図 18 X-ray Anomalous ScatteringのWebサイトにおける
Niの吸収端のフォトンエネルギーと波長。f ′ と f ′′ の
エネルギー依存性の表も参照できる。

5. グラフを見終わったら、 Ctrl +W を押して xdc-Ni.pdfを閉じる。
6. 秀丸エディタで「ファイル > 全終了」を選ぶ。

RIETAN-FPは f ′ と f ′′ を入力しないか、ともにゼロと入力すると、両者を自動計算するという
機能をもつ。残念ながら、吸収端のごく近傍で f ′ を自動計算すると、f ′ vs. λ カーブ中の段差のた
めに補間が正常に機能せず、f ′ が異常な値になる。吸収端付近の波長では、自分で f ′ と f ′′ を入力
することが望ましい。

5.4.6 一次プロファイル・パラメーターのファイル出力
一般に、プロファイル関数に含まれるプロファイル・パラメーターは

1. 非線形最小二乗法で直接精密化する二次プロファイル・パラメーター (Secondary Profile
Parameter: SPP)、
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2. 一次パラメーター81）(Primary Profile Parameter: PPP)

に分類できる [24]。SPP は精密化パラメーターの表に、PPP は反射リストに出力される。
RIETAN-FPが備えている部分プロファイル緩和の機能を使う際には、必要に応じて PPPの 2θ 依
存性をプロットし、PPPが物理的に意味のない解（たとえば非対称パラメーター A < 1）に陥って
いないことを確認するとよい。
秀丸マクロ listPPP を実行すれば、精密化結果に基づく反射リストを含む hoge.lst から各反射の

PPPを記録した Igorテキストファイル hoge_PPP.itxを作成できる。秀丸エディタで hoge.lstを表
示している状態で Ctrl + E を押してポップアップ・メニューを出した後、“listPPP” を選ぶ。多相
試料では第一相の反射だけ、Kα 特性 X線で回折データを測定した場合は Kα1 反射だけが抽出され
る。次に Igor Proで「データ > Load Waves > Load Igor Text...」を選んでから hoge_PPP.itxを
入力してグラフ化する。

5.5 hoge.insへの結晶データの導入と多相リートベルト解析

cif2ins は Crystallographic Information File (CIF), hoge.cif 中の結晶データをひな形ファイル
template.ins に導入することにより RIETA-FP 用入力ファイル hoge.ins に変換する。一方、
combins は複数の ∗.ins から多相リートベルト解析用入力ファイル multi_phase.ins を自動生成す
る82）。多相リートベルト解析は結晶性物質の定量分析の手段として、実験室規模の応用だけでなく
工業的にも重要である。多相用入力ファイルの作成はとりわけ手間と時間がかかるので、cif2ins と
combinsの活用を推奨したい。

5.5.1 CIFのチェック
cif2ins を実行する前に以下に列挙する点について CIF をチェックすると、hoge.cif → hoge.ins
変換時のトラブルが避けられる。CIF の厳密な記述法については、core CIF dictionary v2.4.2
(coreCIF) [25]を参照せよ。
ICDD の粉末回折・結晶構造データベース PDF-4+は多額のライセンス料を毎年徴収されるにも
かかわらず、付属ユーティリティーが出力する CIF は完璧からは程遠いので、cif2ins でそれを読み
込む際の留意点も含めておく。

1. 結晶系 (_space_group_crystal_system) は triclinic, monoclinic, orthorhombic, te-

tragonal, trigonal, hexagonal, cubicのどれかとする。菱面体 (rhombohedral)格子の空間
群は trigonalとしなければならない。

2. 空間群のシンボル (_space_group_name_H-M_alt) は Excel ファイル documentsUSpace_-
groups.xlsxの A列に記録されている短縮形を使う。

3. 空間群のシンボルは ' 'で囲う。文字列中のスペースを削除してはならない83）。
4. 念のために空間群の番号 (_space_group_IT_number)も記載しておくと、“International Tables

for Crystallography”, Vol. Aを参照するときなどに役立つ。
5. RIETAN-FP で正常に読み込めるようにするために Structure Tidy における標準軸設定
（RIETAN-FP_manual.pdfの Chap. 9を見よ）を採用する。軸設定を Structure Tidy互換に変

81） PPPの θ 依存性の式を使って個々の反射について SPPから計算する。
82） 引き続きリートベルト解析を行う前にmulti_phase.insを適当に改名すべきである。
83） PDF-4+と The Materials Projectが出力する CIFでは、遺憾なことに文字間にスペースが存在しない。
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図 19 PDF-4+データベースの Preferences ダイアログで General タブをク
リックすると、“Show All Space Group Symmetry Operators” という
チェックボックスが表示される。本来、並進位置を含む等価位置の座標
は常に出力すべきであり、このチェックボックスは過去の誤った仕様と
の互換性を保つために追加された。

更するには、VESTAを使うのがもっとも楽である（5.5.2）。
6. 複合格子（体心 I、面心 F、六方 H84）、底心 C）をとる空間群では、等価位置の座標
（_space_group_symop_operation_xyz）のリストに並進位置も含めなければならない。PDF-
4+で CIF を出力する場合は、Preferences ダイアログで “Show All Space Group Symmetry
Operators” をチェックせよ（図 19）。

7. 構造パラメーターとしては少なくとも分率座標 (x, y, z) の値がすべて記録されている必要があ
る。構造パラメータには標準不確かさが付いていることが望ましいが、PDF-4+の出力する CIF
では省略している。

8. 次の二条件
•原子変位パラメーター (B, U , βij)が記載されていない。
•_atom_site_U_iso_- or_equiv, _atom_site_B_iso_or_equivの列に ‘?’（情報なし）が
入力されている。

のどちらかが成立するならば、B = 1Å2 とみなす85）。
9. 次の二条件

•占有率 g が記載されていない。
•_atom_site_occupancyの列に ‘?’（情報なし）が入力されている。

のどちらかが成立するならば、g = 1 とみなす。
10. 各サイトの _atom_site_type_symbol も記載することが望ましい。普通は RIETAN-FP が純
粋な化学種として認めている文字列（RIETAN-FP_manual.pdf 中の Table 17.3 を見よ）を入
力するが、後述の combins で多相リートベルト解析用 hoge.ins を自動作成する際には元素名を
入力し、必要ならmulit_phase.ins中の元素名を適当な化学種名に変更する。

84） 菱面体格子を 3倍の容積をもつ六方格子に変換したもの。
85） PDF-4+では _atom_site_U_iso_or_equivまたは _atom_site_B_iso_or_equivとして ‘.’（ピリオド）が入力さ
れている。しかし “A Guide to CIF for Authors” (p. 12)によれば、‘.’はそこにデータが現れる必要がないことを意味
するため、本来なら ‘?’を置かねばならない。構造パラメーターに不確かさが付されていないのも残念である。
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IUCrが公式に廃絶したデータ項目名がCIF中でしばしば使われていることに注意してほしい [22]。
PDF-4+ が出力する CIFに含まれる _symmetry_..... （たとえば _symmetry_cell_setting）の
使用はもはや控えるべきである86）。また PDF-4+では、結晶データから粉末 X 線回折パターンを計
算するのに用いる CuKα1 と CuKα2 特性 X線の波長としてそれぞれ 1.540 56Åと 1.544 39Å [26]
という時代遅れの値を採用しているのも理解に苦しむ。

5.5.2 VESTAによる CIFの出力
種々の構造データファイルを VESTA で読み込み、必要なら「Utilities > Standardization of

Crystal Data」を選んで結晶データを標準化し、「File > Export Data」を選んでから “File type”
として CIF file (∗.cif)を指定すると、CIFに変換できる。その際、分率座標も標準化される。こうし
て保存した CIF はごく短いファイルに過ぎないものの、cif2ins によって hoge.ins に結晶データを導
入するのに必要十分な結晶データを含んでいる。このファイル変換は cif2ins 実行時のトラブル発生
を防ぐのに有効なので、積極的な活用を推奨する87）。
なお、RIETAN-FPのシミュレーション・モードでも標準化できる。

5.5.3 ListReplaceによる CIFの変換
Windows 用 RIETAN-FP・VENUS 統合支援環境は変換リストによる連続置換マクロ

ListReplace.macと二つの変換リストファイル cif_PDF-4+.txtと cif4MedeA.txtを含む。
cif_PDF-4+.txt は粉末 X 線回折データベース PDF-4+が出力する CIF 中のデータ項目
名 _symmetry_..... を以下の手続きにより _space_group_..... に変換し、結晶系の名前の最初
の文字を小文字に変える (5.5.1)のに使う。

1. RIETAN_VENUS_examplesUBaTiO3UBaTiO3.cifを秀丸エディタで開く。
2. Ctrl + @ を押して ListReplaceを実行すると、「変換リストによる連続置換」のダイアログが現
れる。

3. “区切り記号” として ‘,’が含まれていることを確認する。
4. cif_PDF-4+.txt 中の一部の文字列が右端にスペースを含むため、左下の “両端のスペースを含
む” をチェックする。

5. [置換実行]をクリックする。
6. 変換リストファイルとして RIETAN_VENUSUMacrosUcif_PDF-4+.txt を「上書き禁止」と
して開く。

7. 変換リストに従って変換されたファイルが表示される。
8. “このまま確定する” が選択された状態で Enter を押し、［OK］をクリックする。
9. 「ファイル > 名前を付けて保存」を選び、BaTiO3_new.cifとして保存する。

MedeAは VESTAが出力した CIF (5.5.2)を入力できない。_symmetry_.....というデータ項目
名しか受け付けないためである。高価な商用ソフトウェアが由緒正しい CIF を拒絶するという状況
は不条理極まりない。VESTA で得られた CIF を入力してから ListReplace を実行し、変換リスト
ファイル RIETAN_VENUSUMacrosUcif4MedeA.txt を指定すれば、_symmetry_..... を含む前

86） coreCIFには “This definition has been superseded”と繰り返し明記されている。
87） VESTA が出力する由緒正しい CIF を MedeA が読み込めないのは、IUCr が公式に廃止したデータ項目名
_symmetry_.....を入力するという時代遅れの仕様に留まっているためである [22]。
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世代の CIFに変換できる。
変換前後の文字列を任意の区切り記号（たとえば ‘,’）を間に置いて並べた行を含む変換リストファ
イルさえ用意すれば、ListReplace で容易にテキストファイルを変換できる88）。二つ目の区切り記号
の後ろに ‘r’あるいは ‘regular’を置くと、正規表現 (5.6.2)が使える。変換リストファイルはMacros
フォルダー以外に置いても構わない。後で変更する可能性があるならば、ホームフォルダー以下に保
存する方が便利である。ListReplace は汎用性の高い秀丸マクロなので、粉末回折以外の目的にも大
いに活用できよう。

5.5.4 ひな形入力ファイルの編集
多相リートベルト解析用のひな形ファイル template.insは、combinsによる処理を前提に次のルー
ルに則って記述する。

1. X線回折に対する純粋な化学種の行は

! Elements @N

'Cu' 'Fe' 'O' 'P' /

# End Elements @N|

というように、空白行を入れずに ‘! Elements @N’と ‘# End Elements @N’で囲む。ただし、
しおりを字下げするため行頭にスペースを二つ置く。

2. 各相に対する変数名とラベル名の末尾は ‘@N’ とする89）。変数名は大文字・数字だけからなるの
で、‘@n’は使えない。combins実行時に ‘N’が相番号に置換される。

3. 相に対する情報（相の名称、空間群、選択配向ベクトルなど）のブロックは ‘ ! Phase @N’ と
‘# End Phase @N’で囲む。

4. 計算強度を計算するためのパラメーターのうち、相に対するパラメーターのブロック、
すなわち RIETAN-FP_manual.pdf, Table S-5 中の K = 0〜61 は ‘ ! Parameters @N’ と
‘# End Parameters @N’で囲む。

5. 精密化するプロファイル・パラメーターの数が必要以上に増えすぎないように、第 1相と第 N相
のプロファイル・パラメーターを互いに等しいとする線形制約条件を

! Constraints @N

A(GAUSS01@N,1)=A(GAUSS01@1,1); A(GAUSS01@N,2)=A(GAUSS01@1,2);

A(GAUSS01@N,3)=A(GAUSS01@1,3)|\\

A(LORENTZ01@N,1)=A(LORENTZ01@1,1); A(LORENTZ01@N,3)=A(LORENTZ01@1,3)

A(ASYM01@N,1)=A(ASYM01@1,1)

# End Constraints @N

というように ‘ ! Constraints @N’と ‘# End Constraints @N’で囲んで入力する。2相目以
降に限り ‘N’ が相番号に変更された行が出力される。これらの制約条件が不要なら、行頭に ‘#’
を付加して注釈行に変える。

88） 変換リストファイルの行末にスペースが存在するときは、秀丸エディタにおいて「その他 > ファイルタイプ別の設定
>その他 >保存・読み込み >保存するときの変換」で “保存するときに行末の空白を除去する” のチェックを外してから
［OK］をクリックする必要がある。変換リストファイルを保存してから、設定を元に戻す。

89） ただし、読み飛ばされるプロファイル・パラメーターには 必ずしも ‘@N’を付けなくてもよい。
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template.insは cif2insで処理すべき CIFと同一のフォルダーに置く。

5.5.5 複数の入力ファイルの統合とリートベルト解析
cif2insと combinsの実習では、cif2insによって二つのリン酸塩 Cu3Fe4(PO4)6と Cu3(PO4)2、ピ
ロリン酸塩 Cu2P2O7の CIFを RIETAN-FP用入力ファイル ∗.insに変換し、combinsによりそれら
3 相の混合物用を対象とする入力ファイル multi_phase.ins を作成した後、多相リートベルト解析に
移行する。

1. Cu3Fe4P6_combins フォルダー中の多相リートベルト解析用ひな形ファイル template.ins を開
き、多相解析用の注釈行を説明する。

2. カレントフォルダー中に CIF ファイル *@i.cif (i = 1, 2, 3 …) がそれぞれ一つだけ存在
することを確認する。‘@’ の後ろの数字は相番号を表す。欠番があってはならない。本
実習で使う Cu3Fe4P6_combins フォルダーには Cu3Fe4_PO4_6@1.cif, Cu3_PO4_2@2.cif,
Cu2P2O7@3.cifが存在する。

3. ファイルマネージャ枠で Cu3Fe4_PO4_6@1.cifをダブルクリックして開く。
4. ［cif2ins］をクリックする。
5. bash ウィンドウに cif2ins の標準出力が表示される。標準出力中に警告かエラー・メッセージが
含まれていたなら、CIF を修正してから Enter を押して bash ウィンドウを閉じ、ステップ 4
に戻る。

Checking lengths of lines .....
Lines in this CIF are no longer than 80 characters
Reading a chemical formula and a phase name .....
_chemical_formula_sum: Cu2.93763 O24 Fe4 P6
_chemical_name_common: Cu3Fe4(PO4)6
Phase name: Cu3Fe4(PO4)6
Getting element names and amounts of substances from _chemical_formula_sum .....
Cu: 2.93763
O: 24

Fe: 4
P: 6

Reading information on a space group .....
_space_group_crystal_system: triclinic
_space_group_name_H-M_alt: P -1
_space_group_name_Hall: -P 1
Space-group number obtained from Spgr.daf: 2
Reading lattice parameters .....
Lattice parameters: 7.9297(1) 9.3277(2) 6.2557(1) 107.160(1) 101.012(1) 105.830(1)
Reading a unit-cell volume .....
Unit-cell volume: 406.37(1)
Determining kinds of columns from lines containing '_atom_site_' .....
_atom_site_label
_atom_site_fract_x
_atom_site_fract_y
_atom_site_fract_z
_atom_site_occupancy
_atom_site_symmetry_multiplicity
_atom_site_Wyckoff_symbol
_atom_site_adp_type
_atom_site_U_iso_or_equiv
_atom_site_type_symbol
Reading label/atom and structure parameters for all the sites ...
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M1 0.4478(4) 0.1168(4) 0.3864(6) 1 2 i Uiso 0.001(1) Fe
M2 -0.1967(3) 0.2743(3) 0.2669(4) 1 2 i Uiso 0.015(1) Cu
M3 -0.2798(4) -0.4746(4) 0.0470(5) 1 2 i Uiso 0.005(1) Fe
M4 0 0 0 0.9376 1 a Uiso 0.029(2) Cu
P1 -0.4006(7) -0.1666(6) 0.0983(9) 1 2 i Uiso 0.013(2) P
P2 0.2314(6) 0.3713(6) 0.4037(9) 1 2 i Uiso 0.003(2) P
P3 0.1466(7) -0.2358(6) 0.2303(8) 1 2 i Uiso 0.014(2) P
O1 0.032(1) 0.246(1) 0.288(1) 1 2 i Uiso 0.0070(9) O
O2 -0.462(1) -0.083(1) 0.310(2) 1 2 i Uiso 0.0070(9) O
O3 0.277(1) 0.464(1) 0.249(2) 1 2 i Uiso 0.0070(9) O
O4 0.359(1) 0.278(1) 0.439(1) 1 2 i Uiso 0.0070(9) O
O5 0.270(1) -0.223(1) 0.466(2) 1 2 i Uiso 0.0070(9) O
O6 -0.455(1) -0.347(1) 0.067(1) 1 2 i Uiso 0.0070(9) O
O7 -0.189(1) -0.077(1) 0.134(1) 1 2 i Uiso 0.0070(9) O
O8 -0.475(1) 0.164(1) 0.123(2) 1 2 i Uiso 0.0070(9) O
O9 -0.202(1) 0.332(1) -0.014(2) 1 2 i Uiso 0.0070(9) O
O10 -0.249(1) -0.498(1) 0.358(2) 1 2 i Uiso 0.0070(9) O
O11 0.202(1) -0.054(1) 0.232(1) 1 2 i Uiso 0.0070(9) O
O12 -0.055(1) -0.302(1) 0.206(2) 1 2 i Uiso 0.0070(9) O
Number of sites in the asymmetric unit: 19
Determining kinds of columns from lines containing '_atom_site_aniso_U_' .....
Determining kinds of columns from lines containing '_atom_site_aniso_B_' .....
Writing the top part before the title .....
Writing the title .....
Writing the element names and their amounts of substances .....
Writing the element names .....
Writing f' and f'' (= 0.0) .....
Writing the phase name .....
Writing the space-group number .....
Writing the Hermann-Mauguin symbol .....
Writing the lattice parameters .....
Writing structure parameters .....
Writing the remaining part .....

6. Enter を押して bashウィンドウを閉じると、秀丸エディタにより Cu3Fe4_PO4_6@1.insが開
かれる。template.insから変更された箇所を説明する。

7. ファイルマネージャ枠のファイル一覧を利用し、Cu3_PO4_2@2.cif と Cu2P2O7@3.cif につい
て 3〜6 と同様の手続きを繰り返し、それぞれ Cu3_PO4_2@2.ins と Cu2P2O7@3.ins に変換
する。

8. Cu3Fe4P6_combinsフォルダー内の任意のファイルを表示している状態で［combins］をクリッ
クし、カレントフォルダー中の全 *@∗.ins ファイルを統合し、multi_phase.ins を作成するため
のマクロ combinsを実行する。

9. “multi_phase.ins を生成しました。必要に応じてタイトル、元素名、精密化の指標、線形制
約条件、ファイル名などを変更してしてください。” というメッセージに引き続き、生成した
multi_phase.insが表示される。

10. multi_phase.ins のしおりをアウトライン解析枠に表示し、3 相分のデータが入力されているこ
とを確認する。実習時間が不足気味なので、以下のステップは省略する。

11. リートベルト解析に移行する前に、必要に応じてタイトル、元素名（純粋な化学種の名前）、精
密化の指標、線形制約条件の部分を編集する。各相に対する変数の名前とラベルの末尾に ‘@i’
（i: 相番号）が付いているのは、5.5に記す CIF→ hoge.insコンバーター cif2ins により CIFの
内容を多相リートベルト解析用 hoge.insに導入する際のひな形とするためである。
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12. 精密化の指標 ID(I)は Cu3Fe4P6.insにならって修正する。その際には、M4@1サイトの分率座
標は x = y = 0.0に固定し、第 2・第 3相の構造パラメーターはすべて固定し、なおかつ第 2・
第 3相のプロファイル・パラメーターを第 1相の相当するパラメーターと等しいとみなすことに
注意せよ。

13. multi_phase.insに対応する強度データファイルmulti_phase.int（Cu3Fe4P6.intと同一内容）
の存在を確認した後、［RIETAN］をクリックする。

14. 3相の結晶データや各相の有効粒子半径 R、線吸収係数 µ、粒子吸収係数 τ、質量分率 w、モル
分率 X などが Cu3Fe4P6.lstに出力されていることを確認する。

‘(cor)’ は Brindley (1945) の方法によりミクロ吸収 (microabsorption) を補正した値を示して
いる。

15. ［Plot］をクリックし、リートベルト解析結果の観測・計算・差パターンを眺める。タイトルと
信頼度指標を追加表示する。

16. グラフを見終わったら、 Ctrl +W を押して Cu3Fe4P6.pdfを閉じる。
17. 秀丸エディタで「ファイル > 全終了」を選ぶ。

多相試料用の hoge.insを編集する際には、2012年 1月 13日のブログエントリー「多相リートベル
ト解析用入力ファイルの作成」が参考になるだろう。
最後に強調しておきたいのが、template.insを自分で編集して作成した *@∗.insも combinsで処理
可能なことである。もちろん ‘@N’ の部分を変えてはならない。なお線形制約条件の部分を書き換え
たとしても、combinsは完全に無視する。

5.6 sda.commandによる逐次リートベルト解析

5.6.1 sda.commandの用途
sda.command (sda: script-driven analyses)は hoge.ins中のデータを一部変更した一連のリートベ
ルト解析を逐次実行し、得られた信頼度指標をログファイルに一括出力するためのシェルスクリプト
である。言い換えれば、sda.commandは RIETAN-FPを最小二乗フィッティング（カーネル計算）
のエンジンとする外回り計算を指示通りに行う。たとえば

1. 角度標準試料の粉末回折データを用いる放射光の波長の決定、
2. リートベルト解析における最終的な信頼度指標が精密化パラメーターの初期値に依存するか否か
のチェック、

3. hoge.bkgを作成するためのパラメーター NPICKUP, NREPEAT, CURVATUREの最適化90）、
4. 精密化パラメーターの非線形性が強いため、真値からかけ離れた初期値を与えると発散するとい
うトラブルの解決、

5. 互いに相関の強いパラメーターの交互精密化、
6. 各パラメーターを精密化するか固定するかを決めるための予備解析91）、

90） sda.command中で、各リートベルト解析が終わった後に${hoge}.bkgを削除しなければならない。
91） たとえば精密化するバックグラウンド・パラメーターの最適数を決めるのに使う。
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7. 選択配向ベクトルの決定、
8. 異方的プロファイル・ブロードニングの方向の決定、
9. 最適なプロファイル計算打ち切り範囲の決定、
10. 部分プロファイル緩和の有効性の検証、
11. 温度、圧力、化学組成を変化させて測定した一連の強度データの自動解析（5.6.5）

などで絶大な威力を発揮する。これまで試行錯誤のためリートベルト解析を繰り返すのに費やしてい
た時間と労力を大幅に節約できる。リートベルト解析だけなく、Le Bail 解析における初期積分強度
を変更するといった用途も考えられる。

5.6.2 hoge.sdaの編集
リートベルト解析前に、一連の置換コマンドを通し番号＋ ‘)’ の後ろに記述したテキストファイル

hoge.sdaを hoge.insと同一フォルダーに作成しておく92）。置換エンジンとしては通常 sedを使うが、
より強力なスクリプト言語 Perl や Ruby も利用可能である（5.6.4 参照）。hoge.sda がカレントフォ
ルダーに存在する状態で RIETAN マクロを実行すると、シェルスクリプトのひな形 C:UProgram
FilesURIETAN_VENUSUCommandsUsda.command中に hoge.sdaを導入した形の sda.command
がカレントフォルダーに生成する。
hoge.sda 中の 1), 2), ..... で始まる行は、文字列を置換したリートベルト解析 1), 2), ..... にお
ける hoge.ins 中の置換すべき文字列（正規表現 regexp も可）と置換後の文字列 replacement

を 's/regexp/replacement/'というように指定する。複数の文字列を sedで置換するには;をはさ
みながら 's/regexp/replacement/'を同一行内で必要なだけ繰り返せばよい。sed により文字列を
置換するため、文字列を正規表現 [21]で検索できるのが sda.commandの利点である。拡張正規表現
を使う場合は、sedにオプション -rを追加すればよい。置換の内容を説明するために ‘#’で始まる注
釈行を挿入できる。
hoge.sda の編集が終わったら逐次リートベルト解析を実行し、生成した sda.command を秀丸エ
ディタで開いて関数 replace 中に挿入された一連の置換コマンドをチェックする。0) で始まる行が
無置換のリートベルト解析に相当する。$oは置換前の hoge.ins、$mは置換後の hoge.insを表す。必
要なら、sda.command中の変数 outに代入される文字列、すなわち置換後の hoge.insや解析結果な
どを格納するサブフォルダーの名前を default から変更する。さらに、温度、圧力、化学組成を変
化させて測定した一連の強度データを対象として解析する場合は、整数変数 multi_int を 1 に設定
する（5.6.5参照）。
最低限知っておくべき正規表現に関する基本的な規則は次の通り。

1. ^: 行頭
2. $: 行末
3. *: 直前の文字の 0回以上の繰り返し
4. +: 直前の文字の 1回以上の繰り返し93）

5. .（ドット）: 任意の一文字
6. [ ]: [ ]内の文字のどれかに一致94）

92） BaSO4_sdaフォルダー中の BaSO4.sdaを参照すると、以下の記述が理解しやすくなる。
93） ‘+’を正規表現に含めるときは、sedの後ろに 拡張正規表現のオプション -rを追加する必要がある。
94） たとえば [xyz]は x, y, zの いずれかに、[a-z]は小文字のアルファベットに、[0-9]は十進数字に一致。
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7. ( ): グループ化とキャプチャー
8. 上記のような特別な意味をもつメタキャラクターを普通の文字（リテラル）とするときは、\

（バックスラッシュ）をその直前に付けてエスケープする95）

正規表現という難解そうな用語にたじろぐかもしれないが、1〜9 の基本ルールさえ覚えておけば十
分なので、心配無用である。それに regexp の正否は秀丸エディタの検索ダイアログで容易にチェッ
クできる。“正規表現” と “一周する” をチェックし、“検索” に regexpを入力してから [下検索]を
クリックし、hoge.ins 中の文字列にマッチすることを確認すればよい。複数の箇所が見つかる場合
は、ダミーのスペースを入れたり数値の桁を増やしたりして一箇所にだけマッチするよう工夫すれば
よい。
sda.command のチェックが終わったら、それをダブルクリックして実行する。終了後にログファ
イル%out%U%out%.log（$outは環境変数 outに代入された文字列）が自動表示される。

5.6.3 sdaによる選択配向ベクトルの探査
本実習では BaSO4（直方晶系）の粉末 X線回折データのリートベルト解析で、選択配向ベクトル

[hpkplp] を決定するための予備解析として、[hpkplp] を 4 通りに変更して選択配向パラメーター r1

を精密化し、信頼度指標を比べてみる。時間を節約するために、次の手続きのうち 1〜3 は実行済み
であることをお断りしておく。

1. ファイルマネージャ枠を表示し、BaSO4_sda フォルダー中の BaSO4.ins と BaSO4.sda（本実
習用に編集済み）を開き、一連の置換コマンドを記述した BaSO4.sdaについて説明する。

2. ［RIETAN］をクリックしてリートベルト解析を行う。
3. カレントフォルダーに sda.commandが生成する96）。
4. 秀丸エディタのファイルマネージャ枠で BaSO4 フォルダをクリックしてから生成した

sda.commandを開き、手短に説明する。
5. sda.command の先頭で変数 outに適当な名前を指定すると、そのフォルダーがカレントフォ
ルダーに生成する。以後、選択配向ベクトルの決定に使うので、sda.command では pov (pov:
preferred-orientation vector) を代入する。sda.command を実行すると、そのサブフォルダー
R0, R1, R2, …にそれぞれリートベルト解析 No. 0, 1, 2, …の入出力ファイルが格納され、pov
フォルダーにログファイル pov.logが生成することになる。

6. 関数 replaceにおける caseブロック内の場合分けされた命令

# [100]
0) cp $o $m;;
# [010]
1) sed 's/^IHP1 = 1/IHP1 = 0/; s/^IKP1 = 0/IKP1 = 1/' $o>$m;;
# [001]
2) sed 's/^IHP1 = 1/IHP1 = 0/; s/^ILP1 = 0/ILP1 = 1/' $o>$m;;
# [110]
3) sed 's/^IKP1 = 0/IKP1 = 1/' $o>$m;;
# [011]

95） 厳密には、小数点はエスケープする必要がある。しかし ‘.’ も任意の 一文字に他ならないので、小数点をエスケープし
なくても実害がないことが多い。

96） カレントフォルダーに hoge.sda が存在する場合にリートベルト解析を実行すると、sda.command がカレントファル
ダーに自動的に生成する。ただし ∗.int がカレントフォルダーに二つ以上存在するとトラブルが起きるので、EXPO2014
などで入力する強度ファイルの名前は ∗.intとならないように、たとえば ∗.xyとすればよい。
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4) sed 's/^IHP1 = 1/IHP1 = 0/; s/^IKP1 = 0/IKP1 = 1/; s/^ILP1 = 0/ILP1 = 1/' $o>$m;;
# [101]
5) sed 's/^ILP1 = 0/ILP1 = 1/' $o>$m;;
# [111]
6) sed 's/^IKP1 = 0/IKP1 = 1/; s/^ILP1 = 0/ILP1 = 1/' $o>$m;;

に従ってリートベルト解析 No. 0〜6が順次実行される。0)の前行からわかるように、オリジナ
ルの hoge.insでは [hpkplp] は [100]に設定している。

7. ファイルマネージャ枠のフォルダー一覧で BaSO4_sda を右クリックして「開く」を選ぶとエ
クスプローラーで BaSO4_sda フォルダーが開かれる。sda.command を右クリックしてプロパ
ティを選び、必要なら RIETAN_VENUSUCommandsUbash.exeすなわち BusyBox multi-call
binary に関連付けた後、ダブルクリックする97）。bash のウィンドウに実行中の標準出力が表示
される。

8. リートベルト解析 No. 1〜7が終わると、秀丸エディタがログファイル pov/pov.logを表示する。
ただしユーザーが書き換えない部分は不要なので、‘cp $o $m;;’ は ‘Unchanged’ に置き換えら
れ、‘$o>m;;’は削除される。選択配向ベクトル [010]が最小の Rwp (= 8.569%)を与えたことが
わかる。r2 = 1.101(1) に収束したことから、b 軸方向に伸びた針状結晶の外形をもつという知
見が得られた。針状結晶は a, b, c の値が最も小さい軸の方向に伸長しやすいという一般的傾向
に従っている。

9. pov.log のタブを閉じると、bash.exe のウィンドウが消える。秀丸エディタで「ファイル > 全
終了」を選ぶ。

関数 replace 中の 1)〜7) で始まる行における $oはオリジナルの hoge.ins、$mはデータの一部が
置換された hoge.ins を表す。s/regexp/replacement/は ‘;’（セミコロン）で区切る。2 個以上の
置換コマンドが指定すると、ファイル中のどの行にもコマンドを順番に適用する。*) で始まる行は
逐次リートベルト解析の完了後に不要なフォルダーを削除し、リターンコード flag を 1 にセット
する終了処理に相当する。先頭が 0)と *)の行における命令部分を書き換えてはならない。もちろ
ん ‘#’以降の注釈部分は自由に変更できる。

5.6.4 他の正規表現置換コマンド
正規表現は基本的に半角英数字などの ASCII 文字を扱うものなので、sda.command で処理する

hoge.insは日本語の注釈を含まないテキストファイルとするのが望ましい。本実習では正規表現置換
コマンドとして busybox64.exeに内包されている sedを使用したが、慣れ親しんだスクリプト言語を
インストール済みなら、sed の代わりにそれを使っても構わない。多少オーバースペック気味ではあ
るが、sedより強力な正規表現機能をもつ Perlがお奨めである98）。Perlでは

perl -pe 's/^IHP1 = 1/IHP1 = 0/; s/^IKP1 = 0/IKP1 = 1/'

というように sed を perl -pe に置き換えればよい。-p オプションをつけると次のループの内部に
スクリプトがあるかのように動作する。

while(<>) {

97） ファイルマネージャ枠のファイル一覧で sda.command をダブルクリックしてもテキストファイルとして開かれるだけ
で、実行はできない。

98） たとえば \w（単語を構成する文字）、\d（数字）、\D（数字以外の文字）などのメタキャラクターが使える。
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[PerlScript]

} continue {

print $_;

}

-e オプションはそれに続く文字列をスクリプトとして実行する。Windows 用 Perl の実行環境とし
ては ActivePerlを推奨する。
国産スクリプト言語 Rubyでは、

ruby -pe 'sub(/^IHP1 = 1/,"IHP1 = 0"); sub(/^IKP1 = 0/,"IKP1 = 1")'

というように -peオプションを付け、subメソッド sub(/regexp/,"replacement")を ‘;’で区切っ
て繰り返し入力する。やや冗長だが、regexpと replacement が ( ) で囲まれていて誤入力しに
くい。

5.6.5 複数の強度データを対象とする解析
sda.command は温度、圧力、化学組成を変化させた一連の測定で得られた強度データファイ
ル ∗.int を自動解析するのに、とりわけ役立つ99）。室温から 640K まで温度を変化させて測定した
Sr3Zr2O7の強度データ（9点）を対象とする自動リートベルト解析 [27]の手続きは次の通り。

1. SZOフォルダー中の SZO.sda（本実習用に編集済み）を秀丸エディタで開いて説明する。
2. 秀丸エディタで SZO.ins を開き、［RIETAN］をクリックして通常のリートベルト解析を実行
し、SZOフォルダーに SZO.lstなどに加えシェルスクリプト sda.commandを生成させる。一連
のリートベルト解析を実行し入出力ファイルを保存するためのサブフォルダーは SZO フォル
ダーに収容される。本解析では、そのサブフォルダーの名前を ‘temperatures’とする。

3. sda.commandを秀丸エディタで開き、文字型変数 outを temperaturesに設定する。
4. sda.commandにおいて整数変数 multi_intを 1に設定し、強度データが複数あることを指示し
てから保存する。

5. temperaturesフォルダー中にサブフォルダー R0, R1, R2, .....を作成し、それらの中に強度デー
タファイル SZO.int を解析順に一つずつ置く。ファイル名は共通だが、異なる温度で測定した
データなのは言うまでもない。

6. sda.command をダブルクリックすると、それぞれのサブフォルダーに SZO.ins がコピーされ、
関数 replace 中の命令に従って文字列が置換された後、リートベルト解析が実行され、SZO.lst
などのファイルが出力される。サブフォルダーの数だけリートベルト解析が繰り返される。

7. temperatures フォルダー中にログファイル temperatures.log が生成し、秀丸エディタで開か
れる。

8. bashウィンドウを閉じる。

温度、圧力、化学組成の変化は格子定数の変化を伴う。一般に、リートベルト解析では格子定数の
初期値が真値からかけ離れていると、順調な収束は望めない。したがって収束を安定化するには、
FOX や WinPLOTR などによりあらかじめピークサーチを実行した後、指数づけプログラムを実行
して格子定数を求め、sedなどで ∗.ins中の格子定数と置換することが望ましい。

99） ただし温度、圧力、化学組成の変化が相転移を引き起こさない場合に限る。
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5.7 入出力ファイルの自動保存と信頼度指標の抽出・出力

通常、リートベルト解析は精密化パラメーターの初期値、構造モデル、解析の諸設定などを変
えては繰り返し実行する。hoge.ins 中で NUPDT = 1 と設定し、hoge.ins 中の精密化パラメーター
を更新することもある。その結果、入出力ファイル hoge.ins と hoge.lst は何度も更新される。い
つでも過去の解析に立ち戻れる仕組みが利用できれば、解析効率が高まる。そこで、hoge.ins を
含むカレントフォルダー中に Log_folder フォルダーが存在すると、hoge の前にタイムスタンプ
ddHHMMss+ ‘_’を付加した ddHHMMss_hoge.ins（解析前）と ddHHMMss_hoge.lst（解析後）
を Log_folderフォルダーに自動保存するようにしている。
さらに、秀丸エディタが hoge.*を表示している状態でポップアップメニュー中の “R_indices” を
選ぶと、Log_folder フォルダーに含まれるすべての ddHHMMss_hoge.lst から信頼度指標の部分を
抽出し、カレントフォルダーの hoge.relというファイルに時系列で出力してから、秀丸エディタで表
示する。
La2CuO4 のリートベルト解析を例として、入出力ファイルを自動保存し信頼度指標を抽出・出力
してみよう。

1. 秀丸エディタで La2CuO4.insを開く。
2. ［RIETAN］をクリックする。
3. Log_folderフォルダーにフ ddHHMMss_La2CuO4.ins（実行前）と ddHHMMss_La2CuO4.lst
（実行後）がコピーされたことを Finderで確認する。

4. もう一度［RIETAN］をクリックする。
5. 別なタイムスタンプが付いた La2CuO4.ins と La2CuO4.lst のペアが Log_folder フォルダーに
コピーされたことを Finderで確認する。

6. 秀丸エディタで La2CuO4.*を表示した状態で Ctrl + E を押して “R_indices” を選ぶ。
7. 生成した La2CuO4.relが表示される：

Reliability indices obtained in a series of Rietveld refinements

29102955_La2CuO4.lst
Rwp = 6.231 Rp = 4.813 RR = 11.209 Re = 4.977 S = 1.2521 GofF = 1.5678
RB = 2.021 RF = 1.466 RF^2 = 1.897

29103127_La2CuO4.lst
Rwp = 6.231 Rp = 4.813 RR = 11.209 Re = 4.977 S = 1.2521 GofF = 1.5678
RB = 2.021 RF = 1.466 RF^2 = 1.897

5.8 パターン分解と双対空間法（硫酸バリウム）

5.8.1 双対空間法について
双対空間法（dual-space method。チャージ・フリッピングとも言う） [28, 29]（図 20）では、乱
数で一組の初期位相を発生させ、フーリエ合成で計算した電子密度（単位胞内の voxel 数: N）のう
ち閾値 δ より低い値の符号を反転する100）。得られた電子密度セットからフーリエ変換により位相を
更新する。 その際、強度の弱い反射については位相を π/2 だけシフトし、観測されていない反射の

100） flipには「裏返しにする」、「ひっくり返す」という意味がある。
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図 20 チャージ・フリッピングのフローチャート。構造因子のフーリエ合成が電
子密度、電子密度のフーリエ変換が構造因子に該当する。

|F | はゼロにするという操作を加える。双対空間法では逆空間と実空間を行ったり来たりするため、
dual-space method（双対空間法）とも呼ばれる。
van der Lee [30]は直接法と双対空間法には、位相問題を解決し構造モデルを導出する能力にほと
んど差がないと指摘した。 [12] は双対空間法専用プログラムであり、積分強度抽出機能を欠いてい
るため、ハイブリッド・パターン分解の機能をもつ RIETAN-FPとの連携を通じて BaSO4の構造モ
デルを導出する。
Superflip による双対空間法解析については、Evernote の公開ノート「hoge.inflip の入力データ」
と「粉末 X線回折法による未知結晶構造決定法」(Kanzaki, 2018) が参考になるであろう。後者には
デモンストレーション用ムービーが付随している。

5.8.2 実習手順
1. ファイルマネージャ枠を表示し、BaSO4_LBUBaSO4.insを開く。
2. アウトライン解析枠でしおり ‘Pattern Decomposition’ をクリックし、MEP = 0 に設定す
る。重原子 Ba が含まれているため位相を決めやすく、最大エントロピー・パターソン
(Maximum-Entropy Patterson: MEP)解析は必要ないためである。

3. ［RIETAN］をクリックする。
4. BaSO4.lst における ‘Reliability indices’ のしおりをクリックし、Le Bail 解析の Rwp が

10.648%、局所プロファイル・フィッティング後に 7.942%であることを確認する。
5. ［Plot］をクリックしてハイブリッド・パターン分解の観測・計算・差パターンを表示する。拡
大アイコンをクリックして拡大表示し、グラフ全体をドラッグし、縮小アイコンをクリックして
縮小表示する。グラフを見終わったら Ctrl +W を押して BaSO4.pdfを閉じておく。

6. ［MSCS］をクリックする。Halder–Wagner プロットを見終わったら BaSO4-mscs.pdf は
Ctrl +W を押して閉じておく。

7. BaSO4.inflip のタブをクリックする。双対空間法用プログラム superflip と電子密度マッピング
解析プログラム EDMA (Electron Density Map Analysis) [13]のコマンド、反射リストについ
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て説明する。BaSO4 の場合、通常まったく変更なしに双対空間法が実行できるが、初期位相を
乱数で発生させるため、通常、運の悪い人は失敗する可能性があることを指摘しておく。

8. ［Superflip］をクリックし、双対空間法を実行する。最良の位相、ひいては結晶構造因子から計
算した電子密度が BaSO4.xplorに出力される。

9. VESTAで自動的に BaSO4.xplorが開かれる。等値曲面を眺める。
10. ［EDMA］をクリックすると、電子密度のピークに対し原子を割り付け、BaSO4-EDMA.cif が
出力される。

11. VESTAが自動的に BaSO4-EDMA.cifを開き、結晶模型を表示する。
12. 「Edit > Bonds」を選び、［New］をクリックする。Search additional atoms recursively…, A1:

S, A2: O, Max. length: 1.6Å, ［Apply］,［OK］。
13. スタイルタブをクリックし、“Polyhedral” をチェックする。結晶模型を見終わったら、

Ctrl +W を押して BaSO4-EDMA.cif と BaSO4.xplorを閉じる。
14. 秀丸エディタで「ファイル > 全終了」を選ぶ。

5.9 パターン分解と双対空間法（フッ素アパタイト）

5.9.1 ヒストグラム・マッチングについて
双対空間法によるフッ素アパタイトの構造モデル構築では、ヒストグラム・マッチングの導入が必
要となる。ヒストグラム・マッチングは一般的には、画像のコントラスト調整技法として知られてい
る。タンパク質の解析では、密度修正法 (density modification) の一種として初期位相の改良に用い
られている。実測データから計算された電子密度分布のヒストグラムを作り、組成や構造の似た既知
構造（もしくは理想的な構造）から導出される電子密度分布のヒストグラムと比較し、両者が大きく
異なっている場合は、より現実的なものにヒストグラムを置き換える。この手続きにより初期位相の
改善が期待できる。粉末回折データを用いた双対空間法にヒストグラム・マッチングを導入すれば、
重なった反射の積分強度をより適切に再分配できることが指摘されている [31]。
双対空間法の主な勘所を図 21 にまとめた。試行錯誤でパラメーターを最適化しなければならない
解析が多いことを意識してほしい。

5.9.2 実習手順
1. ファイルマネージャ枠を使って Fapatite_LBUFapatite.insを開く。
2. MEP解析における a, b, c 軸方向に沿った単位胞の最適分割数は空間群と格子定数を入力し、ダ
ミーの原子をどこかに置いた後、VESTA の Utilities メニューで Model Electron Densities を
選び、適当な Resolution を入力すれば、テキストエリアの上方に表示される。アウトライン解
析枠でしおり ‘Voxel numbers’をクリックすると表示される分割数

NVOXA = 132: Number of voxels along the a axis.

NVOXB = 132: Number of voxels along the b axis.

NVOXC = 100: Number of voxels along the c axis.

はこうして決めた101）。

101） 単位胞の分割数が必要ないときは、これら三つの変数をゼロにしておくとよい。
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チャージ・フリッピングの勘所

図 21 チャージ・フリッピング実行時に役立つノウハウ。

3. アウトライン解析枠でしおり ‘Pattern Decomposition’ をクリックする。テキストエリアの下
方で ‘MEP = 1’となっていて、MEP解析を実行するよう指定されていることを確認する。

4. そのすぐ下で、元素名と単位胞中の原子数が正しく入力されていることを確認する。

'Ca' 10.0 'P' 6.0 'O' 24.0 'F' 2.0 /

5. ［RIETAN］をクリックする。計算が延々と続く。休憩または実演 (macOS)とする。
6. Fapatite.lst102）において ‘Reliability indices’ のしおりを選び、Le Bail 解析の Rwp が

9.849%、局所プロファイル・フィッティング後に 7.106%であることを確認する。
7. ［Plot］をクリックしてハイブリッド・パターン分解の観測・計算・差パターンを表示する。拡
大アイコンをクリックして拡大表示し、グラフ全体をドラッグし、縮小アイコンをクリックして
縮小表示する。グラフを見終わったら Ctrl +W を押して Fapatite.pdfを閉じておく。

8. ［MSCS］をクリックする。Halder–Wagner プロットを見終わったら Ctrl +W を押して
Fapatite-mscs.pdfを閉じておく。

9. Fapatite.inflipのタブをクリックし、

•Control parameters for superflip
biso 0.0 → biso 0.1

maxcycles 1500103）

repeatmode 5104）

•Control parameters for histogram matching
histogram composition 0.1

hmparameters 30 30 yes

と変更する。Fapatite.intでは 2θ = 10.9◦ 付近に現れる 100反射が測定範囲に入っていないが、
‘missing bound 0.4 4’ という命令により、その不備が多少補われる。 Fapatite.inflipを保存

102） RIETANマクロでは、あたかも RIETAN-FPがMEP解析も実行するように見せかけている。
103） PCの性能が低い場合や時間が足りない場合は 1000。
104） PCの性能が低い場合や時間が足りない場合は 3。
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図 22 粉末 X 線回折データのチャージ・フリッピング解析で決定したフッ素アパタ
イト中の電子密度分布。このレベルだと artifact（実在しない原子のピーク）
がかすかに見える。c軸上に乗っているのがフッ化物イオン。

する。
10. ヒストグラム・マッチングにより解に到達しやすくするものの、乱数によって初期位相を発生さ
せているにもかかわらず比較的小さい繰り返し数（maxcycles と repeatmode）を指定したた
め、正しい解が得られない可能性があり、なおかつ各受講者の計算時間に差が生じることを強調
しておく。

11. ［Superflip］をクリックし、双対空間法を実行する。30 回おきにヒストグラム・マッチン
グが行われる105）。最終的に、最良の位相、ひいては結晶構造因子から計算した電子密度が
Fapatite.xplorに出力される。

12. VESTAで Fapatite.xplor中の電子密度の等値曲面 (図 22)を眺める。最適な Isosurface levelは
12（任意スケール）である。

13. ［EDMA］をクリックすると、電子密度の極大値に応じて原子を割り付けた後、得られた結晶構
造の CIFファイル Fapatite-EDMA.cifが出力される。

14. VESTAが Fapatite-EDMA.cifを自動的に開く。
15. 「Edit > Bonds」を選び、［New］をクリックする。Search additional atoms recursively…, A1:

P, A2: O, Max. length: 1.8Å, ［Apply］, ［OK］。
16. 回転（矢印アイコン）をクリックしてから Toolsタブ。Drag → Animation → Drag。最後にス
クリーンをクリックする。

17. 拡大・縮小（虫眼鏡アイコンをクリックしてから、左押しでドラッグするかホイールを回転）。
18. スタイルタブをクリックし、“Polyhedral” をチェックする。
19. Ctrl +W を押して Fapatite-EDMA.cifと Fapatite.xplorを閉じる。
20. 秀丸エディタで「ファイル > 全終了」を選ぶ。

5.10 実空間法による未知構造解析

105） かなり時間がかかるため、休憩または実演 (macOS)とする。
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図 23 Cimetidine (C10H16N6S) の球棒模型。イミダゾール環とよばれる
五員環を含む。胃酸の分泌を抑制する作用をもつ。

5.10.1 レプリカ交換法による cimetidineの構造モデル導出
時間が不足気味なので、FOX [6]を使う構造モデル構築の実習では、ヒスタミン H2 受容体拮抗薬

cimetidine（図 23）のシンクロトロン粉末 X 線回折データを解析の対象とし、空間群、格子定数、
Le Bail解析結果、分子の内部座標（Fenske–Hall Z-マトリックス106））などを保存した XMLファイ
ルを入力し、レプリカ交換法による最適構造モデルの探索を一回だけ実行するに留める。
FOXによる構造モデル構築については、Evernoteの公開ノート「Cimetidine の構造モデル構築」
と「粉末 X 線回折法による未知結晶構造決定法」(Kanzaki, 2018) が参考資料としてすこぶる役立
つ。デモンストレーション用ムービーも公開されている。

1. Foxをダブルクリックし、［OK］をクリックする。
2. 「File > Open .xml or .cif」を選んで、アーカイブファイル

RIETAN_VENUS_examplesUFOX_examplesUCimetidine-powder.xml
を指定する。

3. ［Crystals］,［Powder Diffraction］,［Global Optimization］をクリックして、それぞれを説明
する。

4. 「Crystals > Scatters」で “Add Atomic Scattering Power” で含有元素を入力した後、“Add
Atom”、“Add Molecule”、“Add Tetrahedron” などで非対称単位に含まれる原子、分子、原子
団を入力するが、Molecule としては Z-マトリックスのテキストファイルを指定するということ
を説明する。

5. 「Crystals > Display > 3D Display」を選ぶ。
6. 必要なら、結晶模型を表示しているウィンドウを右クリックして「Show Full Unit Cell」を選ぶ
と、単位胞全体にわたり分子が表示される。分子などが正常に表示されているかどうかチェック
する。

7. マウスの左ボタンを押しながらドラッグするとイメージを回転できる。ホイールを押しながらマ
ウスを上下にドラッグすると拡大・縮小でき、左右にドラッグすると遠近感を変えられる。＋・
− を押すことによりイメージを拡大・縮小することもできる。このウィンドウでリアルタイム

106） 構造ファイル変換ユーティリティー Open Babel や分子構造エディター Avogadro などで出力できる。Avogadro は
ファイル形式変換にOpen Babelを利用する。
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表示されるのが現時点における最良構造模型である。
8. ［Global Optimization］をクリックし、Algorithmが “Parallel Tempering” になっていること
を確認する。

9. Global Optimization（赤字）の後ろが Cimetidine Powder Optimizationとなっており、Opti-
mized objectで Crystalと PowderPatternのオブジェクトとしてそれぞれ Crystal:Cimetidine、
PowderPattern:Cimetidine-XRay patternとなっていることを確認する。両 Optimized object
を指定しないと、FOXが異常終了する。

10. 必要なら「Number of trials per run」を変更する。カーソルをボックスの上に移動すると、
Cimetidine の場合は 2 000 000で十分と表示される。実習が遅れ気味だったら、小さめの値を入
力するとよい。

11. “Number of Runs to perform” に適当な値を入力する。デフォールトの−1だと無限回の run
になってしまうので、正の整数を入力する方がよい。今回は時間の節約のために 1を入力する。

12. 「Run/Stop > Multiple Runs」を選ぶとレプリカ交換法による構造モデルの探索が始まり、
cost vs. trial のグラフが表示される（図 24）。マウスをカーブの上に移動すると、costの値が最
下部に表示される。ウィンドウ内の操作によりプロットが見えなくなったら、グラフの左方でマ
ウスを左ダブルクリックすることにより再表示できる。

13. Run No.は一つずつ減っていく。“Number of Runs to perform” がゼロになったら計算終了で
ある。「Solutions > Browse Solutions」を選択すると、各 runの最終 costが表示される。

14. 実習時間が不足しているため途中で止めるには「Run/Stop > Stop Optimization」を選ぶ。過
去に Cimetidine.xml.gz を保存したときの最良値（77975.1 rad−1）以下となっていれば成功だ
が、短時間でのトライアルなので、まず無理だろう。

図 24 FOX でレプリカ交換法により cimetidine の構造モデルを決定しているとき
のスクリーンショット。左上が Global Optimization ダイアログ、右上が現
時点における構造模型、下が cost vs. trialのグラフ。
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15. Costが改善されたなら、∗.xml.gzを別名で保存する。
16. 「Crystals > File > Save as CIF」を選んで CIFを出力し、VESTAで開いて構造モデルの妥当
性を検証する。結合を表示する際には、最大結合距離を C–C: 1.7Å、C–N: 1.6Å、C–S: 1.9Å
と設定する。

17. Ctrl +W を押して CIFを閉じる。
18. FOXを終了する。

5.10.2 Z-マトリックスと並列計算
FOX により有機化合物の構造モデルを構築する過程では、分子の Z-マトリックスが基本的に重要
な役割を受け持つ。CIFを Z-マトリックスに変換するには、いったん CIFを VESTAで入力し、原
子の選択・削除により単一分子だけを表示した後、その分子に含まれる原子のカルテシアン座標を
XYZ 形式のファイルとして保存した後、それを Open Babel で Z-マトリックスに変換するのが安
全・確実である。VESTA は単位胞中に含まれる原子の数に相当する原子をすべて XYZ 形式ファイ
ルに出力するため、このような手続きが必要となる。Avogadro で分子構造を入力・表示した後、Z-
マトリックスとして保存するという手もある。
非対称単位内の原子数が多く探索に長時間を要するときは、Fox.Grid の利用を勧める。ネット
ワーク接続した複数の PC、あるいはマルチコア CPU で利用できる。詳しくはマニュアル中の
“Fox.Grid distributed computing”を参照されたい。

5.10.3 FOXで得られた構造モデルに基づく構造精密化 — 抑制条件の付加
FOXは指数づけ、空間群推定、Le Bail解析の機能をもつ一方、リートベルト解析には使えない。

FOXで出力した CIF中の結晶データを cif2insで hoge.insに導入した後、RIETAN-FPによるリー
トベルト解析に移行するとよい。
FOX により非対称単位内の原子数が多い化合物、とくに分子量の大きい有機化合物や錯体の構造
モデルを構築した後、結晶構造の精密化に移行するとしよう。粉末回折データに含まれている構造情
報を補うために、リートベルト解析において幾何学的パラメーターに抑制条件を課すのが常套手段と
なっている。代表的な手続きは以下の通りである。

1. ORFFE [10]の 201命令（指定した距離以下の結合距離を計算）だけを含む hoge.insを対象とし
てシミュレーションモード (NMODE = 1)に設定してから［RIETAN］をクリックする。

2. ［ORFFE］を 2回実行して原子間距離と結合角を hoge.ffeに記録することを推奨する107）。
3. hoge.ins中の抑制条件挿入箇所、すなわち

Ser. No. Exp. value Allowed dev. Weight {

と

# Place '}' (+ comment) after the last restraint.

の間に入力データが存在せず、行末が CR/LFになっていることを確認した後、保存する。
4. ffe2ins.command中では原子間距離の許容誤差は ‘0.01’、結合角の許容誤差は ‘2.00’をデフォー

107） hoge.ffeがカレントフォルダーに存在する場合は削除しなければならない。
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ルト値としている。必要なら変更する。
5. hoge.*がカレントウィンドウの状態で Ctrl + E を押して “ffe2ins” を選べば、すべての原子間
距離と結合角に対する抑制条件を指定するための行が hoge.ins 中に自動的に挿入される。たと
えば test_ffe2insUtest_ffe2ins.insの場合は次のように変換される。

# The following line is indispensable for ffe2ins

Ser. No. Exp. value Allowed dev. Weight {

1 0.885 0.01 0.0 # H2C-C2

2 0.942 0.01 0.0 # H3C-C3

3 0.988 0.01 0.0 # H4C-C4

4 0.948 0.01 0.0 # H5C-C5

.....

168 115.13 2.00 0.0 # C12-N6-C22

169 116.63 2.00 0.0 # C14-N7-C16

170 115.71 2.00 0.0 # C18-N8-C22

171 115.27 2.00 0.0 # C18-N9-C19

# Place '}' (+ comment) after the last restraint.

ffe2ins は ‘ Ser. No. Exp. value Allowed dev. Weight {’ という行の直後に一連の抑
制条件を挿入するため、その行を削除してはならない。誤って削除すると、hoge.insは不変のままに
留まる。RIETAN_VENUS_examplesUtest_ffe2insUtest_ffe2ins.ins を秀丸エディタで開けば、3
以降の操作を体験できる。
二面角に課す抑制条件は VESTAで球棒模型を表示し、4原子を選択した後、テキストエリアに出力
される座標情報を hoge.insにコピー・ペーストすることにより入力する（RIETAN-FP_manual.pdf,
5.4 を参照せよ）。なお結合角と二面角の計算については、2016 年 3 月 5 日のブログエントリー
「ORFFE による結合角と二面角の計算」が参考になる。
金属有機構造体 (Metal Organic Frameworks: MOF) のような原子数の多い配位子を含む結晶の
リートベルト解析では、幾何学的パラメーターの一部が不自然な値になってしまうため、多数の抑制
条件を付加せざるを得ない。その際には、共役方向法で精密化しないと順調に収束しないことを指摘
しておく。解析に要する時間は必然的に長くなる。

5.11 直接法による未知構造解析

5.11.1 RIETAN-FPと EXPO2014との連携
64 ビット版の EXPO2014 [14] は EXPO2014 download の Web ページからインストーラー

expo-110817-x64_install.exe をダウンロードし、管理者権限で実行してインストールする。
C:UProgram FilesUExpo2014UbinUexpo.exe がプログラムの本体である。ツールバーにドラッグ
して登録しておくとよい。
hoge.ins中で MEP = 1、NEXPO = 1に設定し、粉末回折データ hoge.intを Le Bail法（ハイブリッ
ド・パターン分解）で解析すると、MEP法で改善した重畳反射の観測積分強度を記録した hoge.mep
と未知構造解析システム EXPO2014 用入力ファイル hoge.exp がカレントフォルダーに生成する。
必要に応じて hoge.exp を編集した後、EXPO2014 で読み込めば、直接法で構造モデルを構築で
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きる。直接法は非対称単位内の原子が比較的少ない化合物の構造解析に有効である。直接法の威
力を参加者に実感して頂くため、RIETAN_VENUS_examplesUCimetidine_LB フォルダー中の
Cimetidine.mepと Cimetidine.expから cimetidine（5.10.1参照）の構造モデルを EXPO2014で導
出してみる。
EXPOによる構造モデル構築については、「粉末 X線回折法による未知結晶構造決定法」(Kanzaki,

2018)が参考になる。デモンストレーション用ムービーも公開されている。

5.11.2 実演手順
1. EXPO2014を起動し、ツールバーの左から 3番目のボタンをクリックするか「File > Load and

Go」を選び、入力ファイルとして Cimetidine.exp を選択する。
2. ［Edit］をクリックして Cimetidine.expを開き、簡単に説明する。最初の文字が ‘>’の行は注釈
とみなされる。積分強度は Le Bail 法では求めず、Cimetidine.mep から入力するように設定済
みである。

3. ツールバーの［Quit］をクリックして Cimetidine.expのウィンドウを閉じる。
4. ［Go］をクリックする。
5. 解析が終わると、JAV Molecular Viewer (JAV: Just Another Viewer)が cimetidineの球棒模
型を表示する。この例ではすでに正解が得られている。X 線散乱能が互いに近い C と N を一つ
も取り違えていないのは流石である。

6. EXPO2014 のウィンドウで「Solve > Explore trials」を選ぶと、最大の combined figure of
merit (cfom=0.999)を与える Set 1の解が表示されており、RF = 29.894% だということがわ
かる（図 25）。

7. JAVで「Tools > Add Hydrogens > Automatic」を選び、水素原子が自動付加する。
8. 「View > Preferences」メニューで好みに応じてオブジェクトの見た目を変更できる。“Drawing

Options” でバックグラウンドを白に変える。
9. ツールバー上の［Labels On/Off］をクリックしてサイト名を表示する108）。実際には、イミダ
ゾール環中の N6 原子は H6 原子と結合していないのに対し、N1 原子が H 原子と結合している
ため、修正が必要不可欠である。

10. サイドバーの［Selection mode］をクリックした後、H6原子を左クリックして選択する。
11. 「Modify > Delete Selected atoms or bonds」を選んで H6原子を削除する。
12. N1原子を左クリックして選択する。
13. 「Tools > Add Hydorgens > Aromatic C-H」を選んで N1–H1B結合を発生させる109）。H1B
原子上にカーソルを置くと、最下部に妥当な N1–H1B 結合距離 l(N1–H1B)=0.880Å が表示さ
れる110）（図 26）。

14. 「File > Export Structure」を選び、Cimetidine.cifをカレントフォルダーに保存する。
15. VESTAを起動し、「Edit > Preferences 」を選び、“Start-up search for bonds” をチェックし
てから［OK］をクリックする。

16. VESTA で Cimetidine_H.cif を開くと、一つ以上の原子が単位胞に含まれる分子がすべて表示
される。

108） 再度クリックするとサイト名が消える。ラベルの色は「View > Preferences > Models」で変えられる。
109） 実際は芳香環の C–H結合ではないが、便宜上それを選ぶ。
110） 5.11.3にこの結合距離を変更する方法を記した。

50

http://www.misasa.okayama-u.ac.jp/~masami/sdpd/
http://www.misasa.okayama-u.ac.jp/~masami/pukiwiki/index.php?%CC%A4%C3%CE%B7%EB%BE%BD%B9%BD%C2%A4%B2%F2%C0%CF%CB%A1


図 25 MEP法で改善した観測積分強度から EXPO2014により直接法で Cimetidineの構造モデ
ルを構築し、JAV（右）で球棒模型を表示した後、Explore trialsのウィンドウ（左下）
を開いたところ。背後に隠れているのが EXPO2014のメイン・ウィンドウ。

図 26 JAVで cimetidine分子に H原子を自動発生させ、N6原子と結合していた H原子
を削除し、N1–H1B結合を追加した後の球棒模型。

17. 「Edit > Preferences」を選び、“Start-up search for bonds” のチェックを外す。
18. Ctrl + Q を押して JAVを終了する。
19. ツールバーの左端のボタンをクリックするか「File > Exit」を選び、Enter を押して EXPO2014
を終了する。
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5.11.3 JAVの更なる活用
JAV は種々のフォーマットの構造データファイルを読み込んで分子構造を表示、修正、最適化、
加工できる。種々のフォーマットの構造データファイルさえあれば、事実上、単独でも使える。
VESTA に欠けている魅力的な機能を備えており、それを補完する役割を担える。上記の CIF、
Cimetidine.cifを入力して JAVの操作を練習してみよう。

1. EXPO2014を起動し、「File > Import Structure」を選び、入力ファイルとして Cimetidine.cif
を指定してから［OK］をクリックする。JAV のウィンドウに非対称単位内の原子、すなわち
cimetidine分子が一つ表示される。

2. サイドバーの［Manipulation Mode］をクリックすると、分子を回転できる。ホイールを回すと
拡大・縮小できる。

3. サイドバーの［Zoom mode］をクリックして、マウスドラッグで四角形を描くと、その範囲内
の結晶模型が表示される。この操作は余白の調節にも役立つ。ツールバー上の ［Reset Scale］
または ［Reset view］をクリックすると元に戻る。

4. ツールバー上の［Cell Edges On/Off］をクリックして単位胞を表示する。再度クリックすると
単位胞が消える。

5. ツールバー上の［Symmetry On/Off］をクリックすると単位胞内に存在する原子と同数の原子
が表示される。再度クリックすると、非対称単位内の原子表示に戻る。

6. 「Info > List of Atoms」を選び、全原子に関する構造情報を表示する。［Close］をクリック
する。

7. 「Info > List of Bonds」を選び、全結合を表示する111）。l(N1–H1B)=0.87993Å (No. 3) と
なっている。当該行を選択すると、結晶模型中の相当する箇所が選択状態となる。［Close］をク
リックした後、N1–H1B結合をクリックすると、選択状態が解除される112）。

8. 「Modify > Properties > Bond Properties」を選び、No. 3の l(N1–H1B)を選択し、0.87993
をダブルクリックしてから 0.9に変えてから［OK］をクリックする113）。

9. カーソルを H1B原子の上に移動し、l(N1–H1B)が 0.900Åに変わったことを確認する。
10. サイドバーの［Selection Mode］をクリックし、イミダゾール環およびそれと結合した C・H原
子を選んでから「Tools > Optimize Geometry > Optimize Selected Atoms」を選ぶと、それ
らの原子の座標がメルク分子力場計算114）により最適化される115）。

11. 「Info > Geometry」のダイアログを出し、結合距離、結合角、ねじれ角のどれかをチェックし、
結晶模型中の原子をクリックすれば、幾何学的パラメーターを同ダイアログと結晶模型中に表示
できる。同ダイアログは JAVの背後に隠れてしまうかもしれない。

12. ［Close］をクリックし、ツールバー右端の［Clear distances, angles and torsion angles］をク
リックして結晶模型中の幾何学的パラメーターや線を消す。

13. 「Tools > Powder Diffraction Pattern」を選び、粉末 X線回折パターンを表示する。必要なら
［Settings］をクリックして設定を変える。［Close］をクリックする。

111） 「Tools > Bond Settings」で特定の結合のMinDistとMaxdistをダブりクリックしてから値を変更すると、不要な
結合を削除できる。

112） 一般に、選択されている原子と結合は Selection Modeでそれらをクリックすれば、選択状態が解除される。
113） 同様に「Modify > Properties」メニューで結合角とねじれ角も変更できる。
114） 詳しくは http://www.ba.ic.cnr.it/softwareic/expo/tools/を参照せよ。無機元素を含む化合物では、ユニ
バーサル力場 (universal force field: UFF)計算が適用される。

115） 「Tools > Optimize Geometry > Optimize」を選べば分子全体を最適化できる。
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14. C1原子を選択し、「Modify > Change Species > Nitrogen」を選ぶと、N7原子に変わる。
15. 「Modify > Undo Change Species」を選び、元の C1原子に戻す。
16. Shift を押しながら複数の結合を選択し、「Modify > Delete Bonds」を選び、それらの結合を削
除する。

17. 「Modify > Undo Delete」を選び、削除した結合を復活させる。
18. Ctrl + Q を押して JAVを終了する。
19. ツールバーの左端のボタンをクリックするか「File > Exit」を選び、Enter を押して EXPO2014
を終了する。

この他、有機化合物向きの機能ではないが、 「Tools > Bond Valence Sum」を選んだ後、全サイ
トの bond valence sum（6 節）と配位数が上のリストに表示される。特定のサイトを選択すると、
そのサイトと結合している原子の座標と結合距離を下のリストで見ることができる。

5.12 CimetidineのMPF解析

5.12.1 有機化合物にMPFを適用する意義
MEMに基づくパターンフィッティング（MEM-based Pattern Fitting: MPF） [32]では、パター
ンフィッティング（リートベルト解析および積分強度を固定した全パターンフィッティング）と
MEM 解析を交互に繰り返すことにより単位胞中の電子・核密度分布を高確度で決定する。MPF を
利用できる構造精密化プログラムは、今のところ RIETAN-FP・VENUS システムに限られている。
並列計算が可能な上、厳密解が得られる唯一の無料MEM解析プログラム Dysnomia [15]（図 27）
と世界的に広く普及している強力な 3D 可視化プログラム VESTA [8] が利用できることも同システ
ムの大きな利点である。従来、国内で使われてきた擬最大エントロピー法 zero-th order single-pixel
approximation (ZSPA) はもはやガラパゴス化した時代遅れなアルゴリズムに過ぎないことを強調し
ておく。
一般に有機化合物（錯体）中の結合は共有結合性が高く、化学結合に寄与する電子の割合がかなり
大きい。したがって有機化合物においては、実質的に単位胞中の電子密度（三次元 voxel データ）で
結晶構造を表現するMPF解析（図 28）による信頼度指標の改善が著しく、電子密度分布イメージの

見栄えも良くなる116）。
そこで、cimetidine のシンクロトロン粉末 X 線回折データを MPF で解析して信頼度指標の劇的
な改善を確認した後、電子密度分布を VESTA で視覚化することにより MPF の威力を受講者に実
感してもらう。MEM 解析では最低角の反射が観測されていることが望ましいが、上記の強度デー
タは 020 反射 (2θ = 9.32◦) を含んでおり、好都合である。必要に応じ、MPF_multi_Win.pdf と
Evernoteの公開ノート

•MPF実行時の hoge.ins
•MPF_multi.command使用時の入出力ファイル
•MPF解析時の線形制約条件
•不確かさの重み

116） 不規則分布している原子が含まれていない物質の中性子回折データを解析すると、原子核近傍の等値曲面しか表示さ
れない「寂しい」イメージとなる。
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1.  複数の次数の一般化制約条件
2.  Limited-memory BFGS アルゴリズム
3.  格子面間隔 dに基づく重み付け
4.  離散フーリエ変換 (DFT) と高速フーリエ
     変換 (FFT) の自動切り替え
5.  OpenMPによるスレッドレベルの並列計算

Dysnomia の新機能

国産MEMソフトが採用したZSPA法では最大情報エントロピーに到達し得ない。
LM-BFGS法の採用により厳密解が得られる世界初の無料ソフトが誕生した。

図 27 MEM解析プログラム Dysnomiaに実装された新機能。

*.prf (雛形)からEi 
( i = 1, 2, …)を入力

i = 1 *.prf (雛形)をコピー
Eiの値を変更

MEM解析

全回折パターン
フィッティング

R wpが低下

i = i + 1

MPF_multiのアルゴリズム

Dysnomia No

Yes

*. ins (Rietveld)で 
NMODE = 2に設定

#E=200 300 400 500

RIETAN-FP REMEDY
サイクル

bash で書かれたシェルスクリプトMPF_multi.command

図 28 シェルスクリプト MPF_multi.command を用いる MPF 解析のフロー
チャート。この例では E を 200, 300, 400, 500と変えて σ(|Fo|) を調節し
ている。DysnomiaによるMEM解析と RIETAN-FPによる全回折パター
ンフィッティング (w.p.f.) を交互に繰り返す REMEDY サイクルを通じて
リートベルト解析の構造モデル寄りのバイアスを最小化し、最も確からし
い密度分布を求める。

から詳細な情報を得るとよい。
MEM解析プログラム Dysnomiaについては、文献 [15]（オープンアクセス）と 21012年 12月 25
日のブログエントリー「Dysnomia正式版の公開」を参照されたい。4.7.2で述べたように Dysnomia
という MEM 解析用マクロも存在するが、シェルスクリプト MPF_muliti.command による MPF
解析を推奨している。「大は小を兼ねる」からである。

5.12.2 実習手順
1. CimetidineUCimetidine.insを開く。ネットで配付している RIETAN-FP・VENUSシステムに
同梱している Cimetidine.insに水素サイトを追加したものである。
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2. MEM解析における a, b, c 軸方向に沿った単位胞の最適分割数は VESTAの Utilitiesメニュー
でModel Electron Densities を選び、適当な Resolutionを入力すれば、テキストエリアの上方
に表示される。アウトライン解析枠でしおり ‘Voxel numbers’ をクリックすると表示される分
割数

NVOXA = 98: Number of voxels along the a axis.

NVOXB = 268: Number of voxels along the b axis.

NVOXC = 148: Number of voxels along the c axis.

はこうして決めた。
3. ファイルマネージャ枠に Cimetidine.prf が表示されていたら、新たな同名ファイルが出力され
るように、右クリックして削除する。

4. アウトライン解析枠を表示してから ‘! Update of hoge.ins’をクリックし、Cimetidine.ins中
の精密化パラメーターを最終リートベルト解析において収束した値に更新するため ‘NUPDT = 1’
に変更する。

5. アウトライン解析枠で ‘! MEM analysis’ をクリックし、‘NMEM = 1’ となっていることを確認
する。

6. Ctrl + S を押して Cimetidine.insを保存する。
7. ［RIETAN］をクリックする。
8. Dysnomia用入力データが Cimetidine.prfに出力され、秀丸エディタでオープンされる。さらに

Fo(Rietveld)などが Cimetidine.fosに出力される。
9. 秀丸エディタで Cimetidine.prfのタブをクリックする。|Fo| の不確かさ調節因子 E について説
明する。行の先頭の ‘#’は注釈である。サイクル数は E の増加、すなわち σ(|Fo|) の減少ととも
に増えるため、どうしても収束しないときは E を減らす。Rwp, RB, RF の変化、電子密度分布
の物理的・化学的妥当性、artifact（ゴースト）が出現する等値曲面レベルを考慮して E を最適
化する。

10. E = 5713 rad−1 での REMEDYサイクルを実行するため、‘#_SCIO_’と ‘5697’（だけの行）を
それぞれ ‘_SCIO_’と ‘#5697’（注釈行）に変えて保存する117）：

_SCIO_

#E=5697

#5697

‘#’ の前と ‘=’ の両側にスペースを入れてはならない。‘#E=’ の後ろにスペースで区切った複数の
E を入力することも許される。文字列 ‘_SCIO_’ が ‘#E=’ の後ろの E 値に順次置き換えられ、
σ(|Fo|) の異なる複数の MPF 解析を実行できる。たとえば ‘#E=200 300 400 500’ と入力する
と、各 REMEDYサイクルの解析結果は E200, E300, E400, E500というサブフォルダーに格納
される。

11. ファイルマネージャ枠のフォルダー一覧で Cimetidine を右クリックして「開く」を選ぶとエ
クスプローラーで Cimetidine フォルダーが開かれる。MPF_multi.command を右クリックし
てプロパティを選び、必要なら RIETAN_VENUSUCommandsUbash.exe すなわち BusyBox

117） 不確かさを変えた複数回の REMEDY サイクルは相当時間がかかるため、各自、講習会後に実行してもらう。
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multi-call binaryに関連付けた後、ダブルクリックする。秀丸マクロでなく bash スクリプトを
実行するのは、繰り返し計算に時間がかかり、その間、秀丸エディタが使えなくなると不便だか
らである。

12. bashウィンドウに “The constraints have not been satisfied” というメッセージが出力された
なら、hoge.prf 中の最大サイクル数を適当に増やして収束させる（Cimetidine.prf の場合は大
丈夫）。

13. bashウィンドウを閉じた後、MPF解析のログファイル CimetidineUCimetidine.log（その一部
を下に示す）を開き、MPF 解析の過程で信頼度指標がどのように変化したかを説明する。Rwp

は w.p.f. (whole-pattern fitting) No. 1の実行により約 0.44も減少するのに対し、w.p.f. No. 2
ではわずかに増えるため、1 サイクルで収束したとみなす。リートベルト解析と MPF 解析終了
後の信頼度指標は次のように変化する：

Rwp: 6.805% → 6.368%
Rp: 4.986% → 4.638%
RB: 3.539% → 1.411%
RF : 3.305% → 1.062%

Rietveld [18]が提案した手続き118）により求めた観測積分強度 Io から計算する RB と RF の改
善がとりわけ目立つ。Rwp が増加に転じた後も RB と RF はわずかながら減少していく傾向が
ある。

14. 秀丸エディタがCimetidine.*を表示している状態で [VESTA/lst]をクリックしてCimetidine.lst
を読み込み、単位胞中の原子を表示する。

15. MPF解析の計算結果（Rwp最小）一式は CimetidineUE5711Ucycle1フォルダーに保存される。
Cimetidine.fosが MEMで計算した F (MEM)を記録した w.p.f.用ファイル、Cimetidine.pgrid
が電子密度を記録したバイナリーファイルである。「Edit > Edit Data > Volumetric Data」を
選び、Isosurfaces の［Import…］をクリックして Cimetidine.pgrid を開いて電子密度の等値曲
面を重ねて表示する。

16. Objectsタブをクリックし、C5, C6, S1をチェックしてサイト名を表示する。
17. 「Properties > Isosurfaces > Isosurface level」で No. 1 の等値曲面レベルを選択し、電子密
度レベルを試行錯誤で調節して共有結合を視覚化してみる。Style として “Wireframe” を誤
チェックすると、あたかも等値曲面が漂白されたかのように見えるので、注意せよ。図 29 に示
すように、原子間に結合電子が見えるが、二本の C–S1結合のうち C6–S1結合（l = 1.807Å）
より長い C5–S1結合（l = 1.840Å）の中点付近の電子密度が非常に低いことが目立つ。等値曲
面レベルを 0.8Å−3 まで下げると、ようやく結合で結ばれる。

18. VESTAを終了する。
19. 秀丸エディタで Ctrl +W を押して Cimetidine.*を閉じる。

118） (観測強度 − バックグラウンド強度) を重畳反射の計算強度に応じて比例配分して求めた「実測」強度を横軸に沿って
区分求積する。

56



a

b

C
C

C

Me

N

N C

図 29 シンクロトロン粉末X線回折データのMPF解析で決定した cimetidine
の電子密度分布。等電子密度レベル: 1.11 Å−3。a 軸に沿って単斜単位
胞を二つ積み重ねて表示している。少なくとも一部が青い平面は単位胞
のエッジにおける断面である。C (S 原子と結合)–イミダゾール環–メチ
ル基 (Me)の C–Cおよび C–N結合が視覚化されている。H原子に由来
する「出っ張り」が C原子に対する曲面に現れている。この等値曲面レ
ベルではゴーストピークは見えない。

Cimetidine.logの主要部分:

Rietveld analysis
Rwp = 6.805 Rp = 4.986 RR = 9.888 Re = 2.294 S = 2.9664 ...
RB = 3.539 RF = 3.302 RF^2 = 3.290 E(SCIO) = 5710.63

MEM-based pattern fitting with E = 5711

MEM analysis No. 1
Elapsed time: 176.454 s
Number of cycles = 1431
CONSTR = 1.0001780E+00 RF = 0.007048

wCONSTR = 1.0001780E+00 wRF = 0.007963

w.p.f. No. 1
Elapsed time: 0.953 s
Rwp = 6.368 Rp = 4.638 RR = 9.155 Re = 2.304 S = 2.7632 ...
RB = 1.410 RF = 1.062 RF^2 = 1.065 E(SCIO) = 5677.43

MEM analysis No. 2
Elapsed time: 172.593 s
Number of cycles = 1329
CONSTR = 9.9999023E-01 RF = 0.007428

wCONSTR = 9.9999023E-01 wRF = 0.006375

w.p.f. No. 2
Elapsed time: 1.078 s
Rwp = 6.394 Rp = 4.666 RR = 9.207 Re = 2.304 S = 2.7745 ...
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RB = 1.327 RF = 0.951 RF^2 = 0.953 E(SCIO) = 5686.05

6 CIFを出発点とする結晶学的情報の取得

Cryscalc119）は FullProf Suite120）に含まれる結晶学的計算プログラムであり、Crystallographic
Fortran Modules Library (CrysFML)に依存している。一連のキーワード（＋引数）を入力ファイル
hoge.cfl に記述してから実行し、計算結果を標準出力として受けとる。本実習では、RIETAN-FP・
VENUS 統合支援環境用マクロ cryscalc により CIF（hoge.cif）から cryscalc 用入力ファイル
hoge.cfl121）を作成し、種々の結晶学的情報を入手するための手続きを学ぶ。もちろん hoge.cfl を自
分で書いてから cryscalcマクロで処理することも可能だが、CIFを出発点とすれば結晶データなどを
入力する手間が省ける上、cryscalc.command が主要キーワードを hoge.cfl に追加してくれるという
恩恵にあずかれる。RIETAN-FP 用の入出力ファイル hoge.ins と hoge.lst のような結晶データを含
むテキストファイルを VESTAで読み込み、「File > Export Data」を選び、File typeとして “CIF
file (∗.cif)” を指定してから保存すれば、CIFに変換してから cryscalcで処理できる。

6.1 実習手順

1. Jedit Ω で RIETAN_VENUS_examples/CIF_cryscalc/Fapatite.cif122）を開き、ツールバー上
の［cryscalc］をクリックする。

2. カレントフォルダーに Fapatite.cfl が存在しないため、

READ_CIF Fapatite.cif

CREATE_CFL File=Fapatite.cfl

の 2行からなる Fapatite.cflが生成し、実行可能プログラム cryscalcによって処理される。計算
結果が Fapatite.ccoに出力され、表示される。

3. Fapatite.cfl 中に ‘SG_.....’ というキーワードが含まれていないため、cryscalc.command 中の
function append_keywordsに記述されているヒアドキュメント本体が Fapatite.cfl の末尾に付
加された後、Fapatite.cflが表示される123）。

4. asfdc 中に原子散乱因子計算用データが収録されていないイオン（たとえば P+5）がキーワード
ATOMのフィールド No. 2として入力されていると、GEN_HKLコマンド実行時に構造因子が
計算できず、反射リストに ‘0.00000’ や ‘NaN’ が出力されてしまう。実害はないものの、見かけ
が良くない。CIF を変換した直後の Fapatite.cfl ではフィールド No. 2 はすべて元素記号なの
で、その恐れはない。再び［cryscalc］をクリックする。

5. 詳細な結晶学的情報が Fapatite.ccoに再出力され、表示される。
6. 全サイトの bond valence sum, V [33]を計算するために、キーワード ATOMのフィールド No.

2を O-2, P+5, Ca+2, F-1, というように元素記号＋酸化数に変える。元素記号と酸化数の間にス

119） CRYSCALC user’s guide: http://www.cdifx.univ-rennes1.fr/progs/cryscalc/cryscalc.html
120） https://www.ill.eu/sites/fullprof/
121） キーワードと引数はファイル名や元素名などを除き大文字、小文字のどちらでもよい。行頭に ‘!’ か ‘#’ を置くと、注
釈行となる。

122） Fapatite.cifは lst2cifにより出力された CIFである。
123） 結合距離計算命令 ‘CONN ALL’ の後ろで最小距離を MIN=、最大距離を MAX=により指定できる。結合角計算命令

‘CONN ANG’ はWindows用 cryscalcをハングさせるため、注釈としてある。
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ペースを入れてはならない。
7. 前述のように ATOMのフィールド No. 2に ‘P+5’が含まれているので、Fapatite.cfl中のキーワー
ド GEN_HKLを ‘!GEN_HKL’と注釈化する。

8. Cryscalc がデフォールトで使う結合原子価パラメーター R0 とそれに対応する定数 B 以
外の値を指定したい場合は、ポップアップ・メニューで Bond valence parameters を選んで
bvparm2016.cifを参照し、

! Input 'BVPARM Cation Anion Ro B', .....

の次に R0 と B を指定する行を挿入する。

例： BVPARM Na+1 O-2 1.803 0.37

BVPARMの引数 No. 1と No. 2にはキーワード ATOMの 2番目の引数を入力しなければならない。
本実習では、キーワード BVPARMは不要である。

9. 注釈行 ‘! Calculate bond valence sums’の直後の行から冒頭の ‘!’を削除し、‘CONN BVS’と
する。

10. ［cryscalc］をクリックする。
11. Fapatite.cco が表示される。INFORMATION FROM TABULATED X-RAY SCATTERING FACTORS の
下に出力されている反射リストによれば、最低角に現れるのは 2θ = 10.895 35◦, d = 8.11379 Å
の 010 反射である。一方、フッ素アパタイトのリートベルト解析（5.4 参照）で出力された
Fapatite.lstからは、2θ = 18.929◦, d = 4.68452 Åの 110反射が最初の反射だったので、010反
射を観測していなかったことがわかる。

12. Fapatite.ccoの末尾に V の一覧 (summary.bvs)が付加されていることを確認する。

同じフォルダー中の Bi4O12Ti3.cif も同様の手続きで処理できるので、自習してほしい。なお、
Windows用 cryscalcは結合角計算用命令 CONN ANG を使うとハングすることに注意せよ。

6.2 Fapatite.cco中の重要情報

キーワード SG_ALL によって出力される Wyckoff 位置に関する情報は International Tables for
Crystallography, Vol. Aを参照せずに済むようにしてくれるため、とりわけ役立つ。空間群 P63/m

(No. 176)に属するフッ素アパタイトでは、一般等価位置が

List of all Symmetry Operators and Symmetry Symbols

SYMM( 1): x,y,z Symbol: 1

SYMM( 2): x-y,x,z+1/2 Symbol: 6+ (0,0,1/2) 0,0,z

SYMM( 3): -y,x-y,z Symbol: 3+ 0,0,z

SYMM( 4): -x,-y,z+1/2 Symbol: 2 (0,0,1/2) 0,0,z

SYMM( 5): -x+y,-x,z Symbol: 3- 0,0,z

SYMM( 6): y,-x+y,z+1/2 Symbol: 6- (0,0,1/2) 0,0,z

SYMM( 7): -x,-y,-z Symbol: -1 0,0,0

SYMM( 8): -x+y,-x,-z+1/2 Symbol: -6+ 0,0,z; 0,0,1/4

SYMM( 9): y,-x+y,-z Symbol: -3+ 0,0,z; 0,0,0
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SYMM( 10): x,y,-z+1/2 Symbol: m x,y,1/4

SYMM( 11): x-y,x,-z Symbol: -3- 0,0,z; 0,0,0

SYMM( 12): -y,x-y,-z+1/2 Symbol: -6- 0,0,z; 0,0,1/4

と出力される。SYMM( 7)が原点に対称心が存在することを示している。その下に特殊位置が続く：

Special Wyckoff Positions for P 63/m

Multp Site Representative Coordinates (centring translations excluded)
6 h x,y,1/4 x-y,x,3/4 -y,x-y,1/4

-x,-y,3/4 -x+y,-x,1/4 y,-x+y,3/4

6 g 1/2,0,0 1/2,1/2,1/2 0,1/2,0
1/2,0,1/2 1/2,1/2,0 0,1/2,1/2

4 f 1/3,2/3,z 2/3,1/3,z+1/2 2/3,1/3,-z
1/3,2/3,-z+1/2

4 e 0,0,z 0,0,z+1/2 0,0,-z
0,0,-z+1/2

2 d 2/3,1/3,1/4 1/3,2/3,3/4

2 c 1/3,2/3,1/4 2/3,1/3,3/4

2 b 0,0,0 0,0,1/2

2 a 0,0,1/4 0,0,3/4

ただし Space groups を実行すると表示される空間群リストにおける A 列（左端）の Hermann–
Mauguin シンボルが hoge.cfl 中のキーワード SPGR の引数となっている必要がある。言い換えれ
ば、RIETAN-FP互換の標準的軸設定に基づく結晶データでなければならない。
さらに SG_ALLは hkl 反射が出現する条件と関連対称要素も出力してくれる：

>>> Serial reflections conditions for screw axes:
---------------------------------------------------

#52 00l: l=2n; screw axis // [00l] axis with 3c/6 translation (63)

00l: l = 2n、すなわち l が偶数の 00l 反射という条件が [00l]らせん軸の存在に起因することがわか
る。消滅則がどんな種類の複合格子、映進面、らせん軸と関係しているかを具体的に知ることがで
きる124）。
キーワード SITE_INFO ALLにより各サイトの異方性原子変位パラメーター βij に課せられる制約
条件が得られるのも便利である。たとえば O1サイトに対する出力

--> Constraints on anisotropic ADP (11 22 33 12 13 23):

11.00 21.00 31.00 41.00 0.00 0.00

は β11, β22, β33, β12 を独立に精密化し, β13 = β23 = 0 に固定することを意味する。
‘CONN ALL MAX=3.0’ と入力すると、全サイトについて 3.0Å 以下の原子間距離が出力される。

124） 文献 [20]の 4.5.3と 4.8を参照せよ。
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‘CONN Ca1 MAX=2.9’の場合、Ca1サイトに対し 2.9Å以下の原子間距離が得られる。
上述のように、キーワード BVPARMは全サイトの V を hoge.ccoの末尾に出力させる。

Atom Coord D_aver Sigm Distort(x10-4) Valence BVSum(Sigma)

O1 4.00 2.2480( 0) 338.405 -2.000 1.967( 0)

O2 4.00 2.2070( 0) 274.203 -2.000 2.008( 0)

O3 4.00 2.2989( 0) 430.094 -2.000 1.963( 0)

P 4.00 1.5504( 0) 1.702 5.000 4.796( 0)

CA1 9.00 2.5531( 0) 57.496 2.000 2.079( 0)

CA2 7.00 2.4278( 0) 26.486 2.000 2.007( 0)

F 3.00 2.3038( 0) 0.002 -1.000 0.861( 0)

Coord は配位数、D_aver は平均結合距離、Valence は酸化数、BVSum は V を表す。陽イオンだ
けでなく陰イオンでも V > 0 となる。V は結合距離だけから実質的な酸化状態を見積もるのに役
立つ。
本機能は部分占有サイトを含む不定比化合物も扱える。i 番目のサイトが占有率 gi のイオン Ai

(i = 1〜n)によって占有されており、Ai が占有率 gj の対イオン Xj と結合しているならば、Vi は

Vi =
n∑

i=1
gi

∑
j

Vij =
n∑

i=1
gi

∑
j

gj exp
(

R0ij − Rij

B

)

によって算出できる。ただし Vij は Ai–Xj 対の結合原子価、R0ij は Ai–Xj 対の結合原子価パラ
メーター (Å)、Rij は Ai–Xj 結合距離 (Å)、 B は経験的な定数（通常 0.37Å）を示す。上式から明
らかなように、陽イオンだけでなく陰イオンでも Vi > 0 となる。

7 リートベルト解析結果のドキュメンテーション

7.1 文書の内容

cif2pdf125）と E2J (English to Japanese)は RIETAN-FP・VENUS統合支援環境に特化した CIF
→ PDF変換ユーティリティーである [16]。CIF、hoge.lst、グラフフィックファイル、付録ファイル
から次に列挙するデータや図表などを含む PDFファイルを生成する。

•化合物名
•化学式
•化学式量 (chemical formula weight) Mr

•結晶系（三斜晶系, 単斜晶系, 直方晶系126）, 正方晶系, 六方晶系, 三方晶系127）, 立方晶系）
•Hermann–Mauguinの空間群シンボル128）（番号）
•Hallの空間群シンボル
•原点における対称心の有無（centrosymmetricまたは noncentrosymmetric）

125） cif2pdf と cif2ins のエンジンは一心同体の Fortran プログラムであり、引数によってどちらの機能を使うかを指定
する。

126） Orthorhombic system。2014年以前は斜方晶系と呼ぶのが一般的だった。
127） 菱面体晶系とも呼ばれる。
128） Excelファイル documentsUSpace_groups.xlsxのA列に記録されている短縮形。
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•格子定数 a, b, c, α, β, γ

•単位胞体積 V

•単位胞中の式単位 (formula unit)数 Z

•密度 Dx

•sin θ/λ = 0 における構造因子 F (000)
– X線回折: 単位胞中の総電子数
–中性子回折: 単位胞中の干渉性散乱長 bc の合計

•放射線源, 特性 X線, 波長 λ

•光学系, 発散スリット
•2θmin, 2θmax, ステップ幅 ∆2θ, 回折強度の数
•非線形最小二乗法で精密化したパラメーターの数
•線形制約条件の数

ද 2: ϑοૉΞύλΠτ Ca5(PO4)3F (Z = 2) ෼཰࠲ඪɼ౳ํੑࢠݪมҐύϥϝʔλʔɼ

઎༗཰ɽmW͸ଟॏ౓ʴWyckoff Λද͢ɽ߸ه

αΠτ mW x y z U/Å2 g

O1 6h 0.3242(3) 0.4854(3) 1/4 0.0094(9) 1

O2 6h 0.5918(4) 0.4698(4) 1/4 0.0094(9) 1

O3 12i 0.3392(3) 0.2573(3) 0.0698(3) 0.0106(6) 1

P 6h 0.3973(2) 0.3679(2) 1/4 0.0070(3) 1

Ca1 4f 1/3 2/3 0.0013(2) 0.0082(3) 1

Ca2 6h 0.2418(1) −0.0080(2) 1/4 0.0067(2) 1

F 2a 0 0 1/4 0.018(1) 1
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3

図 30 E2J が出力した PDF ファイルにおける構造パラメーターの表とリートベル
ト解析パターンの図（同一ページ）。キャプションは少しだけ補筆した。
IUCr発行の雑誌では、等方性原子変位パラメーターとして B でなく a, b,
c 軸方向の熱振動の程度が直接認識できる U (= B/8π2)を報告するよう推
奨している。Gnuplot のグラフは余白を自動的に切り取られるため、ほど良
い大きさで貼り付けられる。
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図 31 E2J が出力した PDF ファイルにおける結晶構造と電子密度分布の図
（同一ページ）。後述のようにいずれも VESTA で PNG 形式ファイルと
して出力し、GraphicConverterにより余白を切り取った後、PDFファ
イルとして保存した。

•信頼度指標 Rwp, Re, S (= Rwp/Re), Rp, RB, RF 2 , RF

•結晶構造パラメーター： サイト名, 多重度＋Wyckoff記号, 分率座標 (x, y, z), 等方性原子変位
パラメーター U , 占有率 g（図 30）

•異方性原子変位パラメーター U11, U22, U33, U12, U13, U23

•リートベルト解析結果の観測・計算・差パターン（図 30）
•原子間距離 l

•結合角 φ

•二面角 ω（あらかじめ ORFFEの 003命令で計算しておく必要がある）
•結晶構造模型（図 31）
•電子・干渉性散乱長密度分布のイメージ（図 31）
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•Williamson–Hallまたは Halder–Wagnerプロット129）

•ミクロ歪み ε (= ∆d/d) と結晶子サイズ D130）

•一般等価位置の座標131）

•観測可能な反射の回折指数 hkl, 回折角 2θ, 格子面間隔 d, 観測積分強度 Io, 相対積分強度
Io(rel)132）, 構造因子の絶対値 |F |, 半値全幅 H

7.2 LATEX文書の組版

7.2.1 TeX Liveのインストールと更新
cif2pdfと E2Jの両マクロは巨大な TEXディストリビューション TeX Liveのインストールを必要
とするため、実演に留めざるを得ない。後日、参加者が cif2pdfと E2Jを使いたくなったら、CTAN
のミラーサイト133）から TeX Liveのインストーラー install-tl-windows.exeをダウンロードし、管理
者権限で実行して C:Utexliveフォルダーにインストールすればよい。TeX Liveに含まれるすべての
パッケージを更新するには、bin フォルダー中の tlmgr-gui.exe をダブルクリックし、［導入済みのも
のをすべて更新］をクリックする。

7.2.2 LATEX用スクリプトの修正
組版用スクリプト cif2pdf.command, E2J.command, Typeset.command, BibTeX.command,

MakeIndex.commandでは

PATH="C:/texlive/2018/bin/win32;C:/texlive/2017/bin/win32;${PATH}"

というように TeX Live 2018または 2017の実行形式プログラムを含むフォルダーをパス指定してい
る。将来、TeX Liveを更新したならば、上記の ∗.command に記載されている絶対パス中の “2018”
を変更しなければならない。

7.2.3 組版用ファイルセット
cif2pdf_E2J_Fapatiteフォルダーには RIETAN-FP・VENUSシステムのプログラムが出力した
ファイル、すなわち

•Fapatite.cif: lst2cif（2016年 1月 26日のブログエントリー「反射リストからデータを抽出して
CIFを作成するシェルスクリプト」参照）で作成した結晶構造データ、幾何学的パラメーター、
反射リストなどの CIF

•Fapatite.pdf: RIETAN-FPによるリートベルト解析結果に基づいて Plotマクロでプロットした
観測・計算・差パターン（図 14）

•Fapatite-struct.pdf: VESTAなどで作画した結晶模型
•Fapatite-density.pdf: フッ素アパタイトのMPF解析結果から VESTAで作画した電子密度分布

129） Halder–Wagner プロットは Williamson–Hall プロットに比べ信頼性の低い高角度領域よりは低角・中間角度領域に
より大きな重みを置くという利点がある。

130） 結晶性の良い標準試料における広がりの寄与が差し引かれた場合、言い換えれば instrument.gpd がカレントフォル
ダーに存在する場合に限り ε と D を hoge.lst から入力し、PDFファイルに出力する。

131） 原点に対称心がある場合は反転位置の座標、複合格子の場合は並進位置の座標も含む。
132） 最強反射の強度を 100としたときの相対強度。
133） ftp://ftp.u-aizu.ac.jp/pub/tex/CTAN/systems/texlive/tlnet/
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イメージ
•Fapatite-mscs.pdf: MSCSマクロで作成した Halder–Wagnerプロット
•append.pdf: 組版により生成する PDF ファイルの末尾に追加すべき付録ファイル134）。
“International Tables for Crystallography”, Vol. A中の空間群 P63/mのページと図 17相当の
グラフ

などが含まれている。グラフとイメージはいずれも PDF ファイルとして保存する。もちろん他の
解析結果を処理するときは、上記ファイル名中の “Fapatite” を他の文字列に置き換えなければなら
ない。
Fapatite-struct.pdfと Fapatite-density.pdfは VESTAで「File > Export Raster Image」を選ぶ
ことにより出力した PNG 形式ラスターイメージファイルの余白を GraphicConverter で切り取った
後、PDFファイルとして保存した。macOS標準のプレビューを使う場合は、「ツール > 長方形で選
択」を選んで余白をカットし、「ファイル > 書き出す」により PDFファイルとして保存する。他の
プログラムで作成したイメージでも差し支えないが、組版の際、適切な位置に配置するために、余白
は必ず切り取っておく。
なお、Gnuplotで pdfcairoターミナルに出力したグラフの余白は自動的に切り取られる。

7.2.4 組版の手続き
上記のファイルセットさえ揃えば、それらを対象とする LATEX 文書化の手続きは非常に簡単で
ある。

1. cif2pdf_E2J_Fapatite フォルダー内の Fapatite.cif（Fapatite.* なら別なファイルでもよい）
を秀丸エディタで開く。

2. ［cif2pdf］を選んで上に列挙したファイルから LATEX 文書 Fapatite-report.pdf を pdfLATEX で
組版し、Sumatra PDFで表示する。

3. ［E2J］をクリックし、Fapatite-report.pdf を和訳135）することにより日本語文書 Fapatite-
report-j.pdfを作成し、Sumatra PDFで表示する。

4. こうして得られた英文と和文の報告書の一部を変更するには、それぞれ Fapatite-report.tex と
Fapatite-report-j.tex を秀丸エディタで編集する136）。必要に応じ、図表のキャプションに化合
物名や鉱物名などを追加するとよい。

5. 図の大きさをチェックし、必要なら ‘\includegraphics[width=’の直後の数値を変更する。
6. ステータスバーで［Typeset］をクリックして組版する137）。
7. Sumatra PDFを終了する。
8. 秀丸エディタを終了する。

図 30と図 31は E2Jによる組版で得られた PDFファイルから 2ページ分を抽出したものである。
無味乾燥になりがちな技術文書の見栄えがグラフやイメージの挿入により向上することがよく理解で
きよう。

134） PDFファイル編集コマンド qpdf (4.6参照)により追加する。
135） 実際には sedによる Fapatite-report.texの連続処理によって英語の文字列を日本語の文字列に繰り返し置換した後、

pLaTeX + dvipdfmxで組版しているに過ぎない。
136） 小数点を含まない結合角の値にはダミーの ‘.’（小数点）を挿入し、小数点揃えを 可能にする。
137） もちろん TeXworks, TeXShop, TeXstudioなどの TEX用統合環境を利用してもよい。
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7.2.5 cif2pdfと E2Jの存在意義とパフォーマンス
CIFは単なるテキストファイルであり、互換性には優れているものの、科学情報を過不足なく伝え
るだけの表現力を持ち合わせていない。理工系文書に頻出するイタリック、ボールド、上付き、下付
き、オーバーライン、ギリシャ文字、特殊文字などの書体や複雑な数式については、完全にお手上げ
である。広く普及している Microsoft Word はそれらを表現できる一方、数式が美しいとは言い難
く、拙劣なカーニングのせいでしばしば不適切な文字間スペースを与える。Word には業務用品質の
印刷は荷が重い。
そこで CIF を RTF, PDF, HTML などのファイルに変換するためのコンバーターが出現した。
その代表例が publCIF である。しかし Word 互換の RTF ファイルは前述のように薄汚い。それを
PDF化したところで質が向上するわけでない。
自作ソフトで作画した種々のイメージやグラフを全自動で挿入するだけでなく、付録まで追加して

LATEX 文書として組版するという究極進化形は、筆者の知る限り皆無である。pdflatex（英文）と
platex+dvipdfmx（和文）を組版エンジンとする高速タイプセット、視覚に訴求するグラフとイ
メージと付録がもたらす豊富な情報量、LATEX 文書ならではの美しさには感嘆の声が上がるに違いな
い。cif2pdf と E2J のペアは RIETAN・VENUS システムに大きな付加価値を付与する秀逸な文書
化ツールとして高く評価されると確信している。
Windows・macOS用 TeX Liveのインストールとパッケージの更新については、2016年 3月 6日
のブログエントリー「macOS・Windows用 TeX Liveのインストール」に詳述した。今後、cif2pdf
と E2Jを使って行きたいという方は参照していただきたい。

8 可動イオンの拡散経路の可視化

8.1 可動化学種の空間分布計算法

自動車の電動化（EV シフト）に起因する二次電池の需要拡大を受け、正極材料における陽イオ
ンの移動経路を手軽に調べるためのフリーソフトウェアに対する需要が高まっている。Materials
Studio が利用できる恵まれた経済環境なら 3DBVSMAPPER を使うという手もあるが、「鶏を割く
に焉んぞ牛刀を用いん」という感が強い。一方、PyAbstantiaは西村真一氏（東京大学）が開発した
フリーソフトウェアである。Pythonで書かれており、律速段階だけ Fortranプログラムが受け持つ。
Pythonだけでなく数値計算ライブラリー NumPyも必要となる。
PyAbstantiaには Adamsらが提案した二通りの手法

•Bond-Valence Sum138）(BVS) [35, 36]
•Bond-Valence Energy Landscape (BVEL) [37]

が組み込まれている。

8.1.1 BVS
BVSモードについては Evernoteの公開ノート「BVSの 3D分布計算プログラム PyAbstantia」が
役立つ。西村氏から教えて頂いた情報は細大漏らさずそこに記録した。BVS 値 V (target) と理想値

138） Bond softness-sensitive BVS [34]を含む。
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V (ideal) との差の絶対値、
|∆V | = |V (target) − V (ideal)| (1)

を 0.1〜0.4 としたとき連続的な空間が得られることが望ましいが、たとえこの範囲から逸脱しても、
連続的な経路が見えさえすれば BVS分布の傾向は把握できよう。
小さな可動イオンの場合、構造中に比較的大きな空間が存在すると、その壁の近傍で BVS が理想
値に近くなってしまう。また、イオン半径が近い同符号イオンのサイトも安定な場所とされる可能性
が高い。これらは、BVS が対イオンとの距離のみに基づく指標であることに起因する本質的な欠点
である。BVS は極度に単純化したモデルに立脚しており、無視している効果が多い。その限界をよ
くわきまえた上で使用せねばならない。

8.1.2 BVEL
BVEL に関する文献 [37] はオープンアクセス（DOI: 10.1002/pssa.201001116）である。BVEL
は、モース型類似のポテンシャルと遮蔽付きクーロン反発139）からエネルギーを計算してマッピング
する。比較的軽い計算であり、後述の並列処理も可能なことから、非力な PC でも 30 秒以内に終了
するだろう。イオンの拡散障壁を評価するため、Li+ イオンであれば障壁が 1 eV 未満であることが
望ましく、特性が良いものは 0.6 eV を切る物質が多いが、BVEL ではこの見積もりは当てはまらな
い。これは、BVELのエネルギースケール自体にそれほど妥当性がないこと、構造の緩和や揺らぎを
考慮していないことに起因する。最小エネルギーより 1〜1.5 eV ほど大きいレベルで連続した等値曲
面が得られるならば、拡散経路としてもっともらしいと見なせる。もちろん、より小さい値でも連続
的な経路が見えるに越したことはない。RIETAN-FPでは Li+以外に H+, Na+, Mg2+, Al3+, K+,
Ca2+ も扱える。
Morseポテンシャルは原子位置に近づいていくと発散するし、静電反発も同様である。その結果、
原子位置に極めて近い voxelのデータが無限大となり、初期等値曲面が適切に見積れずに NaN (Not
a Number)を与えることがあるが、等値曲面レベルを設定すれば正常に表示される。

8.2 RIETAN-FPと PyAbstantiaの連携

RIETAN-FP（シミュレーション・モード）と PyAbstantia の連続実行によりイオン伝導体にお
ける可動化学種の三次元分布を計算した後、3D ボクセルデータのバイナリーファイルBVS.pgrid あ
るいはBVEL.pgrid を出力すれば、VESTA で等値曲面として視覚化できる。hoge.ins 中には化学種
として H, Li, Na, Mgのどれかが含まれていなければならない。
RIETAN-FP・VENUS統合支援環境上で PyAbstantiaを実行することの利点は次の通り。

1. PyAbstantia により結晶データを CIF から入力する際には pymatgen (Python Materials
Genomics) で単位胞に相当する原子を発生させるが、その段階をスキップできる。すなわち
pymatgenをインストールせずに済む。

2. RIETAN-FP 用入力ファイル hoge.ins で PyAbstantia 関係のデータを入力するため、あ
たかも RIETAN-FP が PyAbstantia を内包しているかのような感じでBVS.pgrid あるい
はBVEL.pgridが得られる。

3. RIETAN-FP のリートベルト解析・シミュレーション機能や ORFFE による幾何学的パラメー
ターの計算なども平行して活用できる。

139） クーロン反発の遮蔽法が厳密から程遠いという謗りを免れない。
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4. PyAbstantia による計算終了後に支援環境内で VESTA による結晶模型の作画に移行しうる
（8.3）。

PyAbstantia は hoge.ins 中で NPYABST = 1 または NPYABST = 2 に設定されたならば、RIETAN
マクロで最後に実行される。あたかも RIETAN-FP が PyAbstantia を内蔵しているかのように見
える。RIETAN.command中の "C:/Program Files/PyAbstantia/pyabst.py"の後ろに -mpオプ
ションを付加すれば、並列処理により計算スピードが劇的に増す。デフォールトは -mp 2 である。
マルチコア CPUを使用する場合、コアの数を考慮し変更して差し支えない。
Windows 上で PyAbstantila を実行するのに必要な環境を整えるための手続きについては、

Evernoteの公開ノート「Windows用の pythonと numpyのインストール」が役立つ。Pythonまで
インストーラーに同梱するとファイルサイズが膨れ上がってしまうため、参加者自身にインストール
してもらうか実演に留めざるを得ない。

8.3 実演手順

8.3.1 α-AgIにおける BVS分布
α-AgI (433K; 立方晶系, 空間群: Im3̄m, a = 5.106Å)は代表的な超イオン導電体であり、420〜

828K の温度範囲で超イオン伝導性を示す（828K は AgI の融点）。420K 以上での銀イオン伝導度
は 1.3 S cm−1 に達する。高温相である α-AgIでは I− イオンが体心立方配置をとる140）。Ag+ イオン
はその間隙に相当する 12dサイト (1/4, 0, 1/2)を 16.67%占め、あたかも液体のように振る舞うとい
うことから、副格子融解 (sublattice melting)と呼ばれる。

1. ファイルマネージャ枠を表示し、AgIUAgI.ins を開く。BVS・BVEL の三次元分布はシミュ
レーションモード (NMODE = 1)で計算する。

2. アウトライン解析枠でしおり ‘PyAbstantia’をクリックし、NPYABST = 1（BVSモード）に設
定されていることを確認してから［RIETAN］をクリックする。この入力ファイルには Wright
と Fender [38]が報告した α-AgIの結晶データを入力した。

3. カレントフォルダーに BVSモード用入力ファイル BVS.inpが生成した後、PyAbstantiaがそれ
を入力して BVSの 3Dデータを収めたバイナリーファイル BVS.pgridを与える。

4. Enter を押して bashウィンドウを閉じる。
5. 秀丸エディタのファイルマネージャ枠で BVS.inpをダブルクリックしてから［VESTA/pgrid］
をクリックして、VESTAによって BVS.pgridを開く。

6. 「Style > Volumetric data」で “Show sections” のチェックを外す。
7. 「Properties > Isosurfaces」で No. 1の等値曲面を選び、“Isosurface level” に |∆V | = 0.28を
入力すると、三角形同士が互いに頂点で連結した形の伝導経路が現れる（図 32）。

8.3.2 三元系正極材料における BVEL分布
次にリチウムイオン二次電池の三元系正極材料 Li(Ni1/3Mn1/3Co1/3)O2（平均電圧: 3.6V、1 g当
たりの容量: 160mA·h/g）における BVELの三次元分布を PyAbstantiaで計算し、Li+ イオンの拡

140） 体心立方格子の格子点に相当する 2aサイト (0, 0, 0)を 100 %占有する。
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図 32 超イオン伝導体α-AgI における Ag+ イオンの移
動経路。|∆V |の等値曲面レベル： 0.28。

散経路を VESTAで視覚化してみよう。α-NaFeO2型構造（空間群: R3̄m、三方晶系、a = 2.8657Å、
c = 14.259Å）の酸化物 Li(Ni1/3Mn1/3Co1/3)O2では、ab 面に平行な (Ni1/3Mn1/3Co1/3)O2層間の
8面体サイトを 6配位の Li+ イオンが占めている。三元系正極材料は容量がやや低いものの、寿命と
熱安定性に優れている。

1. ファイルマネージャ枠を表示し、LiMO2ULiMO2.ins を開く。PyAbstantia を利用する際には、
たとえ固溶体であっても仮想的な化学種を使わず、酸化数ゼロの金属（本酸化物の場合、Ni,
Mn, Co）を各サイトに割り当てる。

2. アウトライン解析枠でしおり ‘PyAbstantia’ をクリックし、NPYABST = 2（BVEL モード）
に設定されていることを確認する。この入力ファイルには Idemoto ら [39] が報告した
Li(Co1/3Ni1/3Mn1/3)O2 の結晶データを入力した。各サイトにはイオンでなく元素を割り当て
る。共有結合半径としては、例えば文献 [40]所収の値を使う。

3. ［RIETAN］をクリックする。
4. カレントフォルダーに BVEL モード用入力ファイル BVEL.inp が生成した後、PyAbstantia が
それを入力して BVELの 3Dデータを収めたバイナリーファイル BVEL.pgridを与える。

5. Enter を押して bash ウィンドウを閉じ、秀丸エディタで LiMO2.lst が前面に見えている状態
で［VESTA/lst］をクリックし、Li(Ni1/3Mn1/3Co1/3)O2の単位胞中の原子を表示する。

6. Li原子と BVELの等値曲面の重ね合わせが見やすくなるように、［Properties］をクリックして
から「Atoms > Radius and color」で Liの半径を適当な大きさに減らす。

7. ［Boundary］をクリックし、x と y の最大値を 3に変えて a, b 軸方向に沿った単位胞の数を増
やす。

8. ［Properties］をクリックし、“All unit cells” をチェックする。
9. 「Edit > Edit Data > Volumetric Data」を選び、Isosurfacesの［Import…］をクリックして

BVEL.pgridを開く。［OK],［OK]の順番にクリックする。
10. 「Properties > Isosurfaces」で No. 1の等値曲面を選び、“Isosurface level” に最小エネルギー
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“F(min)” より 1〜1.5 eV だけ大きいエネルギーの絶対値を入力し、その直上で “Negative” を
選ぶ。Li(Ni1/3Mn1/3Co1/3)O2 では−2.5 eV程度が最適値なので、絶対値の 2.5を入力する。

11. ［OK］をクリックして等値曲面と原子とを重ね合わせて表示する。二次元性の顕著な構造に由
来する Li+イオンの拡散経路が一目で把握できる（図 33）。

12. VESTAを終了する。
13. 秀丸エディタを終了する。

8.3.3 三元系正極材料における BVS分布
LiMO2.insにおいて NPYABST = 1に変更してから［RIETAN］をクリックすると、BVSモード用
入力ファイル BVS.inp が生成する。引き続き PyAbstantia がそれを入力した後、|∆V | の 3D デー
タを収めたバイナリーファイル BVS.pgrid を出力する。BVEL 分布の場合と同様に、まず VESTA
で結晶構造模型を表示した後、BVS.pgridを入力すればよい。
前述のように、VESTA による BVS 分布の可視化にあたっては「Style > Volumetric data」で
“Show sections” のチェックを外せば、単位胞内部を遮っていた断面が消え、単位胞内の等値曲面の
全貌を眺め渡しやすくなる。Li(Ni1/3Mn1/3Co1/3)O2 では、等値曲面のレベルを 0.585に設定すると
連続的な曲面が得られる。

9 第一原理計算用誘導構造の構築と検証

9.1 Supercellと粉末回折パターンの活用

占有率 g が 1 未満のサイトを含む不定比化合物の第一原理計算では、格子定数 a, b, c の少なく
とも一つを整数 (≥ 2)倍にした三斜単位胞（空間群: P1）を有し、全サイトの g が 1である誘導構
造 (derivative structure) を構築しなければならない。CPA (Coherent Potential Approximation)
や VCA (Virtual Crystal Approximation)を利用すれば、通常の単位胞を対象とする第一原理計算
が可能だが、両手法にはいくつかの制限がある。たとえば CPA は有限濃度の不規則系を扱う計算手
法ではあるものの、配置平均に対する最良近似に過ぎず、局所的な原子位置の緩和を取り入れた計算
やMEMの計算結果と比較可能な電子密度分布の可視化がエキスパート以外には困難である。
Supercell [17] はマーデルング・エネルギー EM の計算を通じてすべての可能な誘導構造の安定
性を見積もるという点では、一つまたは少数の擬ランダム構造 (Special Quasirandom Structure:
SQS) を導き出す手法 [41] より優れている141）。残念ながら、誘導構造にせよ SQS にせよ、結晶学
的手法による構造モデルの妥当性は検証されないのが常となっている142）。粉末 X 線・中性子回折
パターンの作図は誘導構造の妥当性を判定する簡便なツールとして有用である。二体相関分布関数
(Pair-Distribution Function: PDF)解析 [42]で得られる局所構造に関する情報の利用に比べると、
実験データの解析なしに適用できるという利点を持つ。
本実習では、RIETAN-FP・VENUS 統合支援環境上で supercell マクロ [22] を選んで supercell,

cif2ins143） (5.5 参照), RIETAN-FP, gnuplot を逐次実行することにより第一原理計算用の誘導構造

141） ただし、ドープ金属あるいは空孔が微量な場合はその限りでない。同一サイトを占めるイオンの酸化数が同一の固溶
体、たとえば Pb(Zr,Ti)O3 の処理には役立たずである。

142） 「あくまで、近似構造モデルを対象とするDFT計算に過ぎない」というのが暗黙の了解事項となっている。
143） Supercellが出力した CIF中の結晶データを hoge.ins中に導入するのに使う。
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図 33 Li(Ni1/3Mn1/3Co1/3)O2 における BVEL の三次元
分布。等値曲面レベル: −2.5 eV。9 個の単位胞
を作画した。緑、三色、赤の球はそれぞれ Li,
(Ni1/3Mn1/3Co1/3), Oを示す。

を構築・チェックするテクニックの習得を目指す。

9.2 CIFへの追加入力

Supercell [17]で導出した誘導構造を対象に EM を判定基準とするスクリーニングには、各サイト
の酸化数が必要となる。金属錯体や有機化合物のように酸化数が明白でない場合は「Wikipedia: 酸
化数」中の記述が役立つ。他の CIFに酸化数を追記して supercellマクロで処理するためのノウハウ
を以下に記す。
Supercell は CIF の入出力を Open Babel に任せているため、ICSD が export した CIF でな
くても安定・確実に処理してくれる。多くの CIF 関連ユーティリティーがエラーを引き起
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こす正式な定義 ‘space_group_ .....’ [22] を正常に入力できる。Supercell が出力する CIF も
‘_symmetry_equiv_pos_as_xyz’以外は coreCIF [25]に記載されている正規ルールを遵守している。
Supercellマクロ用シェルスクリプト supercell.commandでは ‘_symmetry_equiv_pos_as- _xyz’を
‘_space_group_symop_operation_xyz’に置換して完成度を高めている。
たとえば VESTA で出力した CIF の場合、次の手続きに従って変更すれば、それを対象として

supercellマクロを実行できるようになる。
まず誘導構造のサイズを指定するための命令

#supercell AxBxC

をファイルの先頭に挿入する。A, B, Cは 2以上の整数である。g < 1 のサイトが多くなるにつれて可
能な欠陥配置が増えるので、A, B, Cを大きくする必要が出てくる。‘_chemical_name_common’には
化合物名を自分で入力しなければならない。粉末回折パターンをプロットするための入力ファイル
hoge.ins におけるタイトルとして使われる。次に全サイトに対するサイト名 と酸化数をサイト数と
同じ行数だけ入力する。厳密にはサイト名と酸化数を対で入力するのは正しくないが、そう入力すれ
ば supercell で直接処理できる。その下に全サイトの結晶構造データが続く。各サイトに対し必要最
小限のデータ、すなわちサイト名、(x, y, z)、g を入力すれば、supercellマクロで処理できる。もち
ろん、他のデータ、たとえば等方性原子変位パラメーター B が含まれていても差し支えない。

9.3 粉末回折パターンによる誘導構造の検証

誘導構造の CIF を VESTA で入力してから、粉末回折パターンをプロットしてみると、格子欠陥
の濃度が比較的高い系では実際の観測パターンと多かれ少なかれ異なることに気づく。当該 CIF は
準安定相、高温相、高圧相のデータなのかもしれない。温度・圧力の効果、構成元素の酸化状態、化
学結合の性質を考慮しないアルゴリズムで CIF から構築した誘導構造が実際の構造とよく一致して
いる保証はない。主要な反射の相対強度が計算・実測パターンの間でかなり異なっているかもしれな
い ｡また P1 は対称性がもっとも低い空間群なので、構造解析で決定した平均構造では、反射が存在
しない 2θ 領域に超格子反射が出現する可能性もある。それらの一部がかなり大きな強度を呈するの
は珍しくない。結晶性物質の粉末回折パターンは人間に喩えると指紋のようなものなので、誘導構造
のパターンがそれとかなり異なっているようではモデルの妥当性に黄信号が灯る。最悪の場合、砂上
に楼閣を築くという事態に陥りかねない。言い換えれば、粉末回折パターンのシミュレーションは誘
導構造と平均構造との乖離を可視化する手段として有効であり、誘導構造のスクリーニングや妥当性
（不完全性）の検証に使える。平均・誘導構造の粉末回折パターンを比較する習慣の励行を呼びかけ
るには、既成ツールを利用するための具体的な手続きを教示するのが効果的である。
平均構造の粉末回折パターンを計算するには RIETAN-FP を使うため、標準的な軸設定になって
いる必要がある。また supercell が出力した CIF には確度の高い回折強度の計算に必要な B が収録
されていない144）。したがって結晶データを手軽に標準化でき、なおかつ B を含む CIF を出力しう
る VESTAの使用を推奨する。
また、cifconv.command で MAKE_INS = 1（∗.ins を出力する）と設定する場合、VESTA で出力
した CIF の利用を前提としている。VESTA は VASP 用の結晶構造データファイル POSCAR を空

144） The Materials ProjectやAtomWorkからダウンロードした CIFには原子変位パラメーター B や U が記録されて
いないにもかかわらず、なぜか粉末回折強度をプロットできる。特定の値（たとえば B = 1 Å2）に固定しているようでは
正確性を欠く。
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間群 P1 の CIF に変換できるため、VASP 用入力ファイルからも同様に粉末回折パターンを作図で
きる。
平均構造と誘導構造の粉末回折パターンの相違は、主として次の二点に由来している。

1. 特定のアルゴリズムで構築した誘導構造における固溶イオンや空孔の三次元分布が実際の配置か
ら多かれ少なかれ逸脱している。

2. 比較的小さい P1 単位胞で誘導構造を近似せざるを得ないため、本来は強度がゼロとなるべき超
格子反射が出現する。

いずれの要因が支配的なのかについては、ケースバイケースで判断するしかない。
template.ins 中で NBEAM = 0 に設定すると、CIF 中の結晶データから粉末中性子回折パターンを
プロットできる。粉末中性子回折パターンは X 線回折では互いに識別しにくい元素を含む化合物、
たとえば三元系正極材料 Li(Ni,Mn,Co)O2 [39] を扱う際に絶大な威力を発揮する可能性がある。X
線・中性子回折パターンを両方ともプロットすれば、これらの問題点をより明確に可視化できよう。
中性子回折データの実測はまったく必要ないことを強調しておく。
原子核が中性子を散乱する能力は束縛干渉性散乱長 (bound coherent-scattering length: bc)と呼ば
れる。全元素の bc が Neutron Scattering Lengthsの PDFファイルで公開されている。Li, Ti, Mn
は bc < 0 なので、中性子回折の利用価値がとりわけ高い。粉末中性子回折用の試料容器に使われる
Vは bc が 0.443 fmと小さく、回折強度に占める Vの寄与を下げるのに役立つ。

9.4 実習手順

VESTA, supercell, RIETAN-FP を併用し、Al2TiO5 [43] の誘導構造を導出し、粉末回折パター
ンをプロットしてみる。直方晶系の固溶体 Al2TiO5 中では、Al と Ti がそれぞれ 0.667 と 0.333 の
占有率で 4c サイト (0, y, 1/4)と 8f サイト (0, y, z)を占める。Supercell, cif2ins, RIETAN-FP,
gnuplotの逐次実行には supercellマクロ [22]を使う。

1. RIETAN_VENUS_examplesUAl2TiO5UAl2TiO5_COD.cif145）を VESTA で 入 力 し、
「Utilities > Standardization of Crystal Data」を選んで空間群 (No. 63)を Bbmmから Cmcm
に変換する。RIETAN-FP で粉末回折パターンを確実にプロットするため、結晶データは常に
標準化しておくことを推奨する。

2. 「Edit > Edit Data > Structure Parameters」を選ぶ。どれか一つのサイトを選択し、Uij と B

が表示されることを確認する。“Anisotropic: U” は “Anisotropic: beta” (= βij)に、“Isotropic:
B” は “Isotropic: U” (= B/8π2)に変更可能である。

3. 「File > Export data」を選び、Al2TiO5.cifとして保存する。
4. 秀丸エディタで Al2TiO5.cifを開く。‘_atom_site_type_symbol’に続く構造パラメーターの行
が 80桁までに収まっていることを確認する146）。

5. 空間群 Cmcmの軸設定では、Al2TiO5 の格子定数は a = 3.591Å, b = 9.429Å, c = 9.636Åと
なる。そこで誘導構造の単位胞サイズを指示するため、

145） CODから入手した CIFでは構造パラメーター・ブロックの前に異方性原子変位パラメーター Uij のブロックが置か
れている。VESTAが Uij を B に変換できるように、両ブロックの位置を交換した。必要に応じて CIF中の等方性原子
変位パラメーターは B に変えておくとよい。

146） B の有効数字は 3桁あれば十分である。有効数字が必要以上に大きいと CIF中の構造パラメーターの行が 80桁を越
えてしまい、cif2insが hoge.insを出力できなくなる。フィールドがタブで区切られていないことも確認せよ。
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#supercell 2x1x1

という行を Al2TiO5.cifの冒頭に挿入する147）。
6. VESTA の export する CIF では ‘_chemical_name_common’ が Windows 版で空文字となる。

‘_chemical_name_common’ を入力しておくと、当該文字列が Al2TiO5.ins における最初のデー
タ（タイトル）として出力される。

7. loop_
_atom_site_label

という 2行の直前に各サイトの名前と酸化数を

\loop_

_atom_type_symbol

_atom_type_oxidation_number

Ti1 4

Al1 3

Ti2 4|

Al2 3

O1 -2

O2 -2

O3 -2|

というように入力してから Al2TiO5.cifを保存する。
8. template.ins をカレントフォルダーに置かれていることを確認する。これを失念すると、EM は
計算されるものの 2x1x1サブフォルダーに粉末回折パターンの PDFファイルが生成しない。

9. 必要なら秀丸エディタでひな形ファイル template.ins を開き、結晶解析で決定した平均構造
のパターンを作成する場合に合わせて LPAIR1 （フリーデル対、hkl と hkl を発生するか否
かのフラッグ）の値を設定する。supercell マクロを実行すると、誘導構造の ∗.ins では必ず
LPAIR1 = 1 となる。LPAIR1 = 0 にしておけば、結晶データから粉末回折パターンをプロット
する際、RIETAN-FP は正常に終了する。対称中心が原点にない平均構造で、より確度の高い
回折強度が必要ならば、template.ins中で LPAIR1 = 1に変更し、cif2ins, RIETAN, gnuplotの
連係プレーによりグラフを作成し直せばよい。空間群 Cmcm は原点に対称中心を持つため、
LPAIR1 = 0に設定する。

10. 秀丸エディタで Al2TiO5.cifを表示した後、ステータスバー上の [F10]をクリックして supercell
マクロを実行する。

11. 平均構造も含め、supercell, cif2ins, RIETAN-FP, gnuplotによる計算結果を収めたファイルは
すべて 2x1x1 フォルダーに置かれる。Al2TiO5_coulomb_energy_l.txt に静電エネルギー的に
安定な誘導構造の CIF20個に対するファイル名と EM が出力される。平均構造と最安定な誘導
構造の粉末 X線回折パターンを図 34に示す。

12. Optional step: template.ins 中でビームの種類を NBEAM = 0（中性子）に変更してから保存
し、上書きを防ぐためにフォルダー名 2x1x1を 2x1x1_Xに変えた後、手続き 10を繰り返せば、
粉末中性子回折パターンが得られ、X線回折の場合と同様に平均構造と最安定な誘導構造の粉末

147） A = B = C = 1の場合でも、単位胞が十分大きければ最適な原子配置を決めてくれることがある。
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図 34 Supercell マクロでプロットした Al2TiO5 の粉末 X 線回折パターン
（Cu Kα1 特性 X 線）。(a) 結晶解析結果を記録した CIF から得られ
たパターン。(b) 静電エネルギー的に最も安定な 2x1x1 誘導構造
(EM = −2646.189 eV) のパターン。

回折パターンを比較できる。超格子反射の強度が一段と高まっていることが一目でわかる。Ti
は bc = −3.37 fmなので、bc = 3.449 fmの Alとのコントラストが顕著なことから、中性子回折
は誘導構造における Alと Tiの三次元分布が完璧とは言い難いことを浮き彫りにした。

13. 秀丸エディタで「ファイル > 全終了」を選ぶ。

VASP 用入力ファイル POSCARあるいは CONTCAR（最終的に得られた構造）を VESTA で
入力し、CIF として保存した後、粉末回折パターンをプロットするための手続きについては、
「POSCAR の変換で得た CIF から粉末回折パターンをプロットする方法」と「RIETAN-FP または
VESTAで出力した CIFからマーデルング・エネルギーを計算する方法」を参照せよ。

10 結言

RIETAN-FP・VENUSシステムの強みと魅力はなんと言っても、

•多相リートベルト解析用入力ファイル hoge.insの自動生成、
•正規表現置換エンジンを活用した逐次リートベルト解析の自動化、
•MEP法による重畳反射の積分強度の改善、
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•結晶構造を電子密度のボクセル値で表現する MPF 解析による電子（X 線回折）・干渉性散乱長
（中性子回折）密度分布の決定、
•RIETA-FP・VENUS システムで得られた結晶構造と電子・干渉性散乱長密度分布を VESTA
によって三次元的に理解できること、

•EXPO2014, FOX, superflip などの強力な未知構造解析プログラムとの密接な連携を図れる
こと、

•lst2cif, cif2pdf, E2J, Typeset, gnuplot, VESTAなどを併用した構造精密化結果のドキュメン
テーション、

•秀丸エディタ (Windows) あるいは Jedit Ω (macOS) 上に構築された RIETAN-FP・VENUS
統合支援環境による効率的なデータ処理

に尽きる。これらは他をもって代えがたい機能といって過言でない。combinsと sdaはリートベルト
解析を加速するターボチャージャーとして役立つ。MEP 法は直接法や双対空間法で正しい解に到達
する確率を高めるはずである。MPF はリートベルト解析で採用した構造モデルの改善にも有効であ
る。VESTA との密接な連携は粉末回折データからの結晶構造解析のエンターテインメント性と魅力
を一層増すと確信している。
リートベルト解析プログラムの陳腐化とコモディティ化が著しい今、上記の先進機能に関する講義
と実習を含む本講習会の意義は大きい。今回習得した技術を今後、各自の研究・開発に活かしていた
だければ幸甚である。

11 配付ソフトウェアの使用許諾条件

本実習用に配付する無料ソフトウェアのうち第三者が開発・配付しているものは、参加者の手間を
省くために筆者が代理でダウンロードしたことをお断りしておく。今後の使用にあたっては、それぞ
れのプログラムの使用許諾条件をお読みいただきたい。すでに述べたように、民間企業ユーザーは
WinPLOTRに対価を支払う必要がある。
拙作プログラムを使って得た研究成果を論文や解説として発表する際には、

RIETAN-FP [7]: F. Izumi and K. Momma, “Three-dimensional visualization in powder diffrac-
tion,” Solid State Phenom., 130, 15–20 (2007).

VESTA [8]: K. Momma and F. Izumi, “VESTA: a three-dimensional visualization system for
electronic and structural analysis,” J. Appl. Crystallogr., 44, 1272–1276 (2011).

Dysnomia [15]: K. Momma, T. Ikeda, A. A. Belik, and F. Izumi, “Dysnomia, a computer program
for maximum-entropy method (MEM) analysis and its performance in the MEM-based pattern
fitting,” Powder Diffr., 28, 184–193 (2013).

ALBA [11]: F. Izumi, “Spectroscopy and Diffraction III,” 5th Series of Experimental Chemistry,
Vol. 11, ed. by Chem. Soc. Jpn., Maruzen, Tokyo (2006), pp. 220–223.

を必ず引用しなければならない。
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